Last Comment Bug 727666 - Worker hang at shutdown with XHR
: Worker hang at shutdown with XHR
Status: RESOLVED FIXED
: hang, regression
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- critical (vote)
: mozilla13
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 687335 (view as bug list)
Depends on:
Blocks: 614146 786987
  Show dependency treegraph
 
Reported: 2012-02-15 17:08 PST by Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
Modified: 2012-08-30 03:25 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (2.23 KB, patch)
2012-02-15 17:08 PST, Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
no flags Details | Diff | Splinter Review
Patch (12.96 KB, patch)
2012-02-16 16:49 PST, Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
no flags Details | Diff | Splinter Review
Patch (17.87 KB, patch)
2012-03-08 16:26 PST, Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
bent.mozilla: review+
Details | Diff | Splinter Review
Part 2 (9.76 KB, patch)
2012-03-09 11:24 PST, Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
bent.mozilla: review+
Details | Diff | Splinter Review

Description Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-02-15 17:08:28 PST
Created attachment 597620 [details] [diff] [review]
Patch

Third time is the charm?
Comment 1 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-02-16 16:49:42 PST
Created attachment 598061 [details] [diff] [review]
Patch
Comment 2 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-02-17 07:12:36 PST
Comment on attachment 598061 [details] [diff] [review]
Patch

Oops, older patch.
Comment 3 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-03-08 10:41:34 PST
*** Bug 687335 has been marked as a duplicate of this bug. ***
Comment 4 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-03-08 16:26:06 PST
Created attachment 604253 [details] [diff] [review]
Patch
Comment 5 Ben Turner (not reading bugmail, use the needinfo flag!) 2012-03-08 17:46:24 PST
Comment on attachment 604253 [details] [diff] [review]
Patch

Review of attachment 604253 [details] [diff] [review]:
-----------------------------------------------------------------

Needs moar comment, r=me with that!

::: dom/workers/XMLHttpRequestPrivate.cpp
@@ +1443,5 @@
>    // may be gone.
>  
>    if (mProxy) {
> +    // This isn't necessary if the worker is going away or the XHR is going away.
> +    if (aType == Default) {

Let's move this inside the 'else' case below. That way it's not so confusing.

::: dom/workers/XMLHttpRequestPrivate.h
@@ +165,5 @@
>  
>    bool
>    SendInProgress() const
>    {
> +    return mJSObjectRooted != 0;

Remove != 0
Comment 6 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-03-09 11:24:46 PST
Created attachment 604472 [details] [diff] [review]
Part 2
Comment 7 Ben Turner (not reading bugmail, use the needinfo flag!) 2012-03-09 11:39:53 PST
Comment on attachment 604472 [details] [diff] [review]
Part 2

Review of attachment 604472 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/workers/XMLHttpRequestPrivate.cpp
@@ +1092,5 @@
>      }
>  
>      mProxy->mPreviousStatusText.Truncate();
>  
> +    mProxy->mInOpen = true;

Please assert !mProxy->mInOpen

@@ +1097,2 @@
>      rv = mProxy->mXHR->Open(mMethod, mURL, true, mUser, mPassword, 1);
> +    mProxy->mInOpen = false;

Please assert mProxy->mInOpen
Comment 8 Marco Bonardo [::mak] 2012-03-13 04:42:13 PDT
I assume the landing was a coalesce of the 2 patches, if not please reopen.

https://hg.mozilla.org/mozilla-central/rev/b02fb1d9d533

Note You need to log in before you can comment on or make changes to this bug.