Confirmation yes/no dialogs don't allow keyboard input

VERIFIED DUPLICATE of bug 64457

Status

()

VERIFIED DUPLICATE of bug 64457
18 years ago
18 years ago

People

(Reporter: ltskinol, Assigned: alecf)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Linux, CVS 13 Mar 2001

I believe this works correcly on Windows, but not on Linux.  It
occurs with both the Modern and Classic themes.

Configure Mozilla (Edit->Preferences->Advanced->Images) to "Alert
me before downloading an image").  Now go to some site with images.
Mozilla pops up a box that says "The site xxx wants to load an image.
Do you want to allow it?"  In the box are Yes and No buttons.  
However, there are no keyboard shortcuts (i.e. the Y and N aren't
underlined).  This makes this "Alert me" feature into a PITA, as
I have to either mouse into the box to click the appropriate button,
or to tab between them and use space or return.  It would be _so_
much better if the Linux version would react to keyboard Y and N's
on these boxes.

Updated

18 years ago
Keywords: access

Updated

18 years ago
Assignee: asa → morse
Component: Browser-General → Cookies
QA Contact: doronr → tever

Comment 1

18 years ago
updating component.  If this is broader than the cookie dialogs please send to
XPApps GUI Features. 

Comment 2

18 years ago
Yes, it's much more general than cookie dialogs.  Reassigning.
Assignee: morse → ben
Component: Cookies → XP Apps: GUI Features
QA Contact: tever → sairuh

Comment 3

18 years ago
Oops, I didn't read the bug report carefully enough.  If it's just a matter of 
the Y/N not being underlined, then it indeed is a problem specific to the cookie 
module.  Reassigning back to myself.
Assignee: ben → morse
Component: XP Apps: GUI Features → Cookies
QA Contact: sairuh → tever

Updated

18 years ago
Assignee: morse → ben
Component: Cookies → XP Apps: GUI Features
QA Contact: tever → sairuh

Comment 4

18 years ago
OK, now that I have a chance to look at this a bit closer, I can state with 
certainty that this is broader than just cookies dialog.

The dialog itself it put up with commonDialogsService.UniversalDialog.  The 
caller of that routine has no control over keyboard navigation capability of the 
resulting dialog.  The same lack-of-navigation will be observed in other places 
that use the routine as well.  For example, when closing a composer window and 
getting asked if you want to save the changes before closing.

It's not completely true that there is no keyboard navigation here.  You can 
still use the tab key to select the various buttons.

Reassigning to "XPApps GUI Features" per Asa comment.
(Reporter)

Comment 5

18 years ago
I double-checked this, and the same problem occurs on Windows.  Changing
platform to All.

Also, please re-read the original bug report.  I do use TAB and Return to
select the yes/no.  A single 'Y' or 'N' hot key would be a huge improvement,
and I think would be expected (on Windows, at least) by most users.
OS: Linux → All
->keybd nav
Assignee: ben → alecf
Component: XP Apps: GUI Features → Keyboard Navigation
Keywords: access

Comment 7

18 years ago

*** This bug has been marked as a duplicate of 64457 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 8

18 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.