if Inbox is Sent folder, show Senders not Recipients

VERIFIED FIXED

Status

--
major
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: jcr, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
since a couple of days, the "sender" column in mail messages list is not
available. In this way, one does not know from whom are arriving mail messages
unless one opens it or reads it.

Comment 1

18 years ago
Sent folder(s) usually has Recipient in place of Sender column.  Is it Recipient
in all folders?  Are you using a current build? 
QA Contact: esther → nbaca
(Reporter)

Comment 2

18 years ago
Inbox shows Recipient (which is a bug). Sent and Draft show Recipient (which is
right). Other folders show Sender (which is right). The build is 2001032016
(Reporter)

Comment 3

18 years ago
I've found the origin of the bug. Please check out the "Place a copy of message
in folder..." in the Account configuration. If you put "Inbox" as the
destination folder of the copy of the sent messages, the Mozilla changes the
Sender column into Recipient column. This is a bug, to me.

Comment 4

18 years ago
Build 2001-03-23-15: NT4
I duplicated the problem. 

In 4.x when the Sent folder is set to the Inbox the column displays the Sender 
folder, even after a restart. Is this how it should work?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

18 years ago
INHO it should remain "Sender", even if the Sent copies are copied there. This
way, one can have the messages and their answers in the same folder and watch
them as a thread, but the Sender has to be put there.

Comment 6

18 years ago
The Inbox should always show the Sender (even if it is set as the "Sent" 
folder).
accepting.

should be an easy fix.
Status: NEW → ASSIGNED
(Reporter)

Comment 8

18 years ago
hallo, what about this bug, very annoying? :-)

Updated

18 years ago
Keywords: nsCatFood

Comment 9

18 years ago
I too place my "sent" messages in my Inbox, so that I can review the threads of
conversation, so would like this to be resolved, but this only works for unfiled
messages. I also like to filter messages such that I have different folders for
different groups of messages. If file my replies to these in the "Sent" folder
(i.e. my Inbox) the threads are broken.

How about an option in the the Copy and Folder Settings area:
  For replies, place a copy in:
which has the normal folder list plus "The folder containing the message replied
to"?

Guess this is more of a feature request than a bug... maybe I should open a
enhancement request.

Comment 10

18 years ago
Please log another bug for the enhancement request.
updating summary to make this bug easier to find.
Hardware: Macintosh → All
Summary: sender column is no more there, just Recipient → if Inbox is Sent folder, show Senders not Recipients

Comment 12

18 years ago
Changing platform
Hardware: All → Macintosh

Updated

18 years ago
OS: Mac System 8.5 → All
Hardware: Macintosh → All

Comment 13

17 years ago
I stumbled into this bug, too. In my case I tried placing a copy into INBOX, but
after that _removed_ the check mark from "Place a copy in:". The destination is
still visible, but dimmed.

What worries me, is that this bug is triggered even if copying to INBOX is
disabled. I suspect the current code isn't checking the state of the checkbox of
"Place a copy in:" and it might lead to other problems, too.

If I move the radio button from "Other:" to "'Sent' Folder on:" before unmarking
the checkbox, the bug is not triggered.
Depends on: 61651
fixed, but risto's scenario sounds like there's more going on here.

I'll investigate and start a new bug.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 15

17 years ago
with 0.9.3 the bug is still there. Mac OS8.6

Comment 16

17 years ago
Build 2001-08-10-03: WinMe

I changed my Sent folder to the Inbox folder. The Sender column is still 
present. When I send a message (I'm 'user1) a copy of the message appears in the 
Inbox and the Sender column displays the recipient's name (user2). This does not 
seem right. When I select and view the message in the Message pane the Sender 
(user1) and Recipient (user2) entries are correct but the Sender column in the 
thread pane displays 'user2' as the Sender.

Comment 17

17 years ago
I'm in a state now where only the recipients are appearing in the thread pane,
even though the column title states "Sender". This is true for all messages. 

As a workaround I tried to set the Sent folder back to the Account's Sent
folder, I've tried deselecting the checkbox to automatically save a copy of the
message to the Sent folder. If I copy a message to a different folder then it
displays the sender as expected. I can't seem to get the Inbox back to a normal
state.

Clarification: Is this bug suppose to ensure that the title of the Sender column
remains "Sender" or is it referring to the user/email that is displayed in the
thread pane under the Sender column?
(Reporter)

Comment 18

17 years ago
first one you said.

The purpouse of the bug is to get the classic very old behaviour so a user can
have "threaded" messages in the inbox, retaining the sender column and names of
sender as referring names.

Comment 19

17 years ago
Verified Fixed, since the column is now titled "Sender".

Bug# 95709 is tracking the problem where the recipient's email address appears
in the Sender column. 
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.