should use clamped scroll position in nsGfxScrollFrameInner::ScrollTo instead of unclamped one

RESOLVED INVALID

Status

()

RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: tnikkel, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Reporter)

Comment 1

7 years ago
Created attachment 598162 [details] [diff] [review]
patch

Bug 627651 replaced mDestination used in the same place with aScrollPosition. Was that intended? Seems like we want the clamped scroll position here.
Attachment #598162 - Flags: review?(mstange)
Comment on attachment 598162 [details] [diff] [review]
patch

Yes, this was intended. I think being near a wall shouldn't have any influence on the animation. Using the clamped position would make the scroll motion slower (in terms of velocity, not completion time).
To me, the previous behavior felt like the edges of the scrolled area had some kind of force field that protected them from a fast scroll collision. It didn't feel right.
Attachment #598162 - Flags: review?(mstange) → feedback-
(Reporter)

Comment 3

7 years ago
Alright.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Reporter)

Updated

7 years ago
Assignee: tnikkel → nobody
You need to log in before you can comment on or make changes to this bug.