Last Comment Bug 728350 - Updated Telemetry help->about message to match notification message
: Updated Telemetry help->about message to match notification message
Status: RESOLVED FIXED
[Telemetry]
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 14
Assigned To: Théo Chevalier [:tchevalier]
:
Mentors:
Depends on: 743979
Blocks: 712636 702284
  Show dependency treegraph
 
Reported: 2012-02-17 12:03 PST by Lawrence Mandel [:lmandel] (use needinfo)
Modified: 2012-04-10 06:24 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch V1 (1.90 KB, patch)
2012-02-17 13:11 PST, Théo Chevalier [:tchevalier]
gavin.sharp: feedback+
Details | Diff | Review
Screenshot (231.87 KB, image/jpeg)
2012-02-17 14:31 PST, Théo Chevalier [:tchevalier]
no flags Details
PatchV2 (3.23 KB, patch)
2012-02-17 14:33 PST, Théo Chevalier [:tchevalier]
gavin.sharp: review+
Details | Diff | Review
PatchV2 (3.45 KB, patch)
2012-02-17 14:42 PST, Théo Chevalier [:tchevalier]
gavin.sharp: review+
Details | Diff | Review

Description Lawrence Mandel [:lmandel] (use needinfo) 2012-02-17 12:03:40 PST
Telemetry currently has an opt-in notification in product. An opt-out notification for Nightly and Aurora users is being added in bug 725407. Telemetry also has text in the help->about dialog (bug 701182). The message for the two notifications matches in terms of detail. The messages are:

opt-in
"Will you help improve %1$S by sending anonymous information about performance, hardware characteristics, feature usage, and browser customizations to %2$S?"

opt-out
"$PRODUCTNAME sends information about performance, hardware, usage and customizations back to Mozilla to help improve Firefox."

The Telemetry help->about message should match the messages that we use in our notification messages. Specifically, I would like to see the about dialogs updated to use the following text:

It automatically sends information about performance, hardware, usage and customizations back to &vendorShortName; to help make &brandShortName; better.
Comment 1 Théo Chevalier [:tchevalier] 2012-02-17 12:15:41 PST
Okay, I'm on it :) Should I update message on mobile as well? (bug 702284)
Comment 2 Lawrence Mandel [:lmandel] (use needinfo) 2012-02-17 12:34:45 PST
Yes. For now let's use the same message on mobile. We may revisit the mobile message after we come up with the appropriate notification message for mobile in bug 728340.
Comment 3 Théo Chevalier [:tchevalier] 2012-02-17 13:11:31 PST
Created attachment 598346 [details] [diff] [review]
Patch V1
Comment 4 Lawrence Mandel [:lmandel] (use needinfo) 2012-02-17 13:14:28 PST
Comment on attachment 598346 [details] [diff] [review]
Patch V1

Review of attachment 598346 [details] [diff] [review]:
-----------------------------------------------------------------

This is the change I would like. Can you confirm with a screenshot that the extra text hasn't affected the overall appearance of the about dialog?
Comment 5 Théo Chevalier [:tchevalier] 2012-02-17 13:17:15 PST
(In reply to Lawrence Mandel [:lmandel] from comment #4)
> Comment on attachment 598346 [details] [diff] [review]
> Patch V1
> 
> Review of attachment 598346 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> This is the change I would like. Can you confirm with a screenshot that the
> extra text hasn't affected the overall appearance of the about dialog?

Thanks Lawrence. I anticipated this, the build is being compiled. :)
Comment 6 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-02-17 13:28:35 PST
Comment on attachment 598346 [details] [diff] [review]
Patch V1

You'll need to change the entity name here (warningDesc.telemetryDesc?), since the string is semantically different, and that's the only way we have of notifying localizers of such changes.
Comment 7 Théo Chevalier [:tchevalier] 2012-02-17 14:31:02 PST
Created attachment 598379 [details]
Screenshot
Comment 8 Théo Chevalier [:tchevalier] 2012-02-17 14:33:41 PST
Created attachment 598381 [details] [diff] [review]
PatchV2

Bug for the background issue is bug 712636.
Comment 9 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-02-17 14:36:14 PST
Comment on attachment 598381 [details] [diff] [review]
PatchV2

You'll also need to change the reference to the entity in the LOCALIZATION NOTE. r=me with that.
Comment 10 Théo Chevalier [:tchevalier] 2012-02-17 14:42:59 PST
Created attachment 598384 [details] [diff] [review]
PatchV2
Comment 11 Lawrence Mandel [:lmandel] (use needinfo) 2012-03-16 08:36:54 PDT
This looks ready to land. Can someone please push to Mozilla inbound?
Comment 12 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-03-19 18:10:04 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/2d2525447715
Comment 13 Mounir Lamouri (:mounir) 2012-03-20 03:47:01 PDT
https://hg.mozilla.org/mozilla-central/rev/2d2525447715

Note You need to log in before you can comment on or make changes to this bug.