Closed Bug 728372 Opened 10 years ago Closed 10 years ago

Get chunk compilation to work on x64

Categories

(Core :: JavaScript Engine, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla13

People

(Reporter: bhackett1024, Assigned: bhackett1024)

References

Details

Attachments

(1 file)

Currently chunk compilation is disabled on x64, due to the extra complexity involved in infallibly patching jumps between different chunks and shim labels.  This can cause huge and confusing performance differences on sites which want to use chunked compilation, e.g. bug 727956 comment 3.
Assignee: general → bhackett1024
Attachment #598342 - Flags: review?(dvander)
Comment on attachment 598342 [details] [diff] [review]
patch (3fa51ff647cb)

Review of attachment 598342 [details] [diff] [review]:
-----------------------------------------------------------------

z
Attachment #598342 - Flags: review?(dvander) → review+
Comment on attachment 598342 [details] [diff] [review]
patch (3fa51ff647cb)

Review of attachment 598342 [details] [diff] [review]:
-----------------------------------------------------------------

(Whoops, hit enter too quick, meant to say): If you wanted to make it simpler you could also just always do the long jump.
https://hg.mozilla.org/mozilla-central/rev/3b8ad7252ccb
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla13
Could this have been the cause of:

Regression :( Dromaeo (SunSpider) decrease 15% on WINNT 6.1 x64 Firefox
-----------------------------------------------------------------------
    Previous: avg 1024.380 stddev 64.070 of 30 runs up to revision 561771f01881
    New     : avg 871.117 stddev 24.855 of 5 runs since revision b8e7474374d5
    Change  : -153.262 (15% / z=2.392)
    Graph   : http://mzl.la/zIYrCm 

Unfortunately (like the other day), not possible to reduce the range further using talos, since Win x64 talos not running on inbound. Range for the merge to m-c was:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=561771f01881&tochange=b8e7474374d5
If there was no similar regression on other x64 platforms, then no.  This bug will affect all x64 platforms equally (and is all in codegen, so there shouldn't be any wacky OS dependent stuff).
Depends on: 741110
You need to log in before you can comment on or make changes to this bug.