gpg signature file missing for the firefox 10.0.2, 10.0.2esr, and 3.6.27 releases on releases.mozilla.org

RESOLVED FIXED

Status

RESOLVED FIXED
7 years ago
5 years ago

People

(Reporter: nanotube, Assigned: aki)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
I looked for the customary .asc gpg detached signature file for firefox 10.0.2 release, in the usual locations:
ftp://releases.mozilla.org/pub/mozilla.org/firefox/releases/10.0.2/linux-i686/en-US/
and 
ftp://releases.mozilla.org/pub/mozilla.org/firefox/releases/10.0.2/linux-x86_64/en-US/
so that I could verify the integrity and authenticity of the release tarballs.

The files were missing, and my mission failed.

Comment 1

7 years ago
Including Aki and Nick who both worked on the 10.0.2 release (bug 727629).
(Assignee)

Updated

7 years ago
Depends on: 726508
nthomas, can you have a look?
Assignee: nobody → nrthomas
Depends on: 727629
(Assignee)

Comment 3

7 years ago
rsync -av --dry-run --ignore-existing --exclude=*tests* --exclude=*crashreporter* --exclude=*.log --exclude=*.txt --exclude=*unsigned* --exclude=*update-backup* --exclude=*partner-repacks* --exclude=*.checksums --exclude=logs --exclude=jsshell* /pub/mozilla.org/firefox/nightly/10.0.2-candidates/build1/ /pub/mozilla.org/firefox/releases/10.0.2/

This is the rsync that copied them over, minus the |--exclude=*/*.asc| , with a --dry-run and --ignore-existing; this updates the contrib directory timestamps and copies over asc files only.
(Assignee)

Comment 4

7 years ago
Run without the --dry-run.
I hit two errors, trying to set the timestamps on the contrib/solaris* directories. Otherwise the .asc files are all copied in.

I'm going to reopen bug 726508 so we stop doing this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
I did the same for 3.6.27 and 10.0.2esr since they had the same problem.
Assignee: nrthomas → aki
Depends on: 727630, 727634
Summary: gpg signature file missing for the firefox 10.0.2 release on releases.mozilla.org → gpg signature file missing for the firefox 10.0.2, 10.0.2esr, and 3.6.27 releases on releases.mozilla.org
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.