Crash @ CReconstructor::AppendFillTailPairs

RESOLVED WORKSFORME

Status

()

Core
Graphics
--
critical
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash, regression, reproducible})

12 Branch
x86_64
Windows 7
crash, regression, reproducible
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

6 years ago
It first appeared in 12.0a1/20120111 but there's a spike in crashes from 13.0a1/20120217. The regression range for the spike is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a853f4017192&tochange=2271cb92cc05

Signature 	CReconstructor::AppendFillTailPairs(CScanner::CChain*, CScanner::CChain*, bool&) More Reports Search
UUID	d44e4c56-be60-4b96-be92-35ff52120207
Date Processed	2012-02-07 04:37:59
Uptime	23
Last Crash	46 seconds before submission
Install Age	7.1 hours since version was first installed.
Install Time	2012-02-06 21:30:41
Product	Firefox
Version	13.0a1
Build ID	20120206031148
Release Channel	nightly
OS	Windows NT
OS Version	6.1.7601 Service Pack 1
Build Architecture	amd64
Build Architecture Info	family 6 model 15 stepping 11
Crash Reason	EXCEPTION_NONCONTINUABLE_EXCEPTION
Crash Address	0x0
User Comments	Surfing to http://duckduckgo.com/traffic.html crashes the browser.
App Notes 	
AdapterVendorID: 0x1002, AdapterDeviceID: 0x68f9, AdapterSubsysID: 23401462, AdapterDriverVersion: 8.850.0.0
D2D? D2D+
DWrite? DWrite+
D3D10 Layers? D3D10 Layers+
EMCheckCompatibility	False	
Total Virtual Memory	8796092891136
Available Virtual Memory	8795532152832
System Memory Use Percentage	25
Available Page File	9907970048
Available Physical Memory	4805156864

Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	google_breakpad::ExceptionHandler::HandleInvalidParameter 	toolkit/crashreporter/google-breakpad/src/client/windows/handler/exception_handler.cc:601
1 	d2d1.dll 	CReconstructor::AppendFillTailPairs

I crash with the same crash reason but with no crashing thread:
bp-14f52471-d284-4113-b011-8ad1c2120218

More reports at:
https://crash-stats.mozilla.com/report/list?signature=CReconstructor%3A%3AAppendFillTailPairs%28CScanner%3A%3ACChain*%2C%20CScanner%3A%3ACChain*%2C%20bool%26%29
(Reporter)

Comment 1

5 years ago
There's only one crash in 22.0 and not able to reproduce on DDG.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.