Closed Bug 728585 Opened 8 years ago Closed 4 years ago

Remove "Mac" from the OS X User Agent

Categories

(Core :: Networking: HTTP, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: morpheus3k+bugzilla, Unassigned)

References

(Blocks 1 open bug)

Details

Apple has officially renamed "Mac OS X" to "OS X". The transition has begun with OS X Lion (alias OS X 10.7). With the release of OS X Mountain Lion (alias OS X 10.8) the "Mac" within the product name is no more.

I suggest to remove the "Mac" to reduce the size of the OS X User Agent. I think the UA could drop the "Mac" for all OS X version, because there exists the redundant "Macintosh" token.
Although I understand that it could be useful to just drop it for 10.7 and newer versions.

This will change the OS X UA
from current:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:13.0a1) Gecko/13.0a1 Firefox/13.0a1

to: (with the removal described in bug 728582)
Mozilla/5.0 (Macintosh; OS X 10.7; rv:13.0a1) Gecko/13.0a1 Firefox/13.0a1
Depends on: 728582
Status: UNCONFIRMED → NEW
Ever confirmed: true
I believe we're settled on the current UA approach
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.