browser_viewsourceprefs.js should not use 'about:robots' which is Firefox specific

VERIFIED FIXED in Firefox 11

Status

()

Toolkit
View Source
P2
major
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: sgautherie, Assigned: sgautherie)

Tracking

(Blocks: 1 bug)

Trunk
mozilla13
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox10 wontfix, firefox11 verified, firefox12 verified, firefox-esr10 affected)

Details

(Whiteboard: [perma-orange][qa-], URL)

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1329533748.1329538419.29635.gz
WINNT 5.2 comm-central-trunk debug test mochitest-other on 2012/02/17 18:55:48
{
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/components/viewsource/test/browser/browser_viewsourceprefs.js | Test timed out
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/components/viewsource/test/browser/browser_viewsourceprefs.js | Found unexpected view source window still open
}
(Assignee)

Comment 1

6 years ago
Created attachment 598602 [details] [diff] [review]
(Av1) browser_viewsourceprefs.js: Use "about:mozilla", instead of "about:robots", to support non-Firefox applications
[Checked in: Comments 3 and 6]

This test does not (seem to) actually depend on 'about:robots', does it?
This change lets this test succeed on SeaMonkey.
Attachment #598602 - Flags: review?(jwein)
Comment on attachment 598602 [details] [diff] [review]
(Av1) browser_viewsourceprefs.js: Use "about:mozilla", instead of "about:robots", to support non-Firefox applications
[Checked in: Comments 3 and 6]

Looks fine to me. I can't review this though, so I've forwarded the review to Neil Rashbrook.
Attachment #598602 - Flags: review?(neil)
Attachment #598602 - Flags: review?(jwein)
Attachment #598602 - Flags: feedback+
Target Milestone: mozilla13 → ---

Updated

6 years ago
Attachment #598602 - Flags: review?(neil) → review+
(Assignee)

Comment 3

6 years ago
Comment on attachment 598602 [details] [diff] [review]
(Av1) browser_viewsourceprefs.js: Use "about:mozilla", instead of "about:robots", to support non-Firefox applications
[Checked in: Comments 3 and 6]

https://hg.mozilla.org/mozilla-central/rev/7df4ef4a3a58


[Approval Request Comment]
Regression caused by (bug #): Bug 702448.
User impact if declined: None, but perma-orange (with timeout) on SeaMonkey.
Testing completed (on m-c, etc.): This comment.
Risk to taking this patch (and alternatives if risky): None, test only.
String changes made by this patch: None.
Attachment #598602 - Attachment description: (Av1) browser_viewsourceprefs.js: Use "about:mozilla", instead of "about:robots", to support non-Firefox applications → (Av1) browser_viewsourceprefs.js: Use "about:mozilla", instead of "about:robots", to support non-Firefox applications [Checked in: Comment 3]
Attachment #598602 - Flags: approval-mozilla-beta?
Attachment #598602 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

6 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla13
(Assignee)

Comment 4

6 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1329822596.1329827961.29626.gz
OS X 10.6 comm-central-trunk debug test mochitest-other on 2012/02/21 03:09:56

V.Fixed
Status: RESOLVED → VERIFIED

Comment 5

6 years ago
Comment on attachment 598602 [details] [diff] [review]
(Av1) browser_viewsourceprefs.js: Use "about:mozilla", instead of "about:robots", to support non-Firefox applications
[Checked in: Comments 3 and 6]

[Triage Comment]
Test only fix - approved for Aurora 12 and Beta 11.
Attachment #598602 - Flags: approval-mozilla-beta?
Attachment #598602 - Flags: approval-mozilla-beta+
Attachment #598602 - Flags: approval-mozilla-aurora?
Attachment #598602 - Flags: approval-mozilla-aurora+
(Assignee)

Updated

6 years ago
Keywords: checkin-needed
Whiteboard: [perma-orange] → [c-n: to m-a and m-b] [perma-orange]
Comment on attachment 598602 [details] [diff] [review]
(Av1) browser_viewsourceprefs.js: Use "about:mozilla", instead of "about:robots", to support non-Firefox applications
[Checked in: Comments 3 and 6]

http://hg.mozilla.org/releases/mozilla-aurora/rev/fdc6d9d791d7
http://hg.mozilla.org/releases/mozilla-beta/rev/2c04d3e4a9ed
Attachment #598602 - Attachment description: (Av1) browser_viewsourceprefs.js: Use "about:mozilla", instead of "about:robots", to support non-Firefox applications [Checked in: Comment 3] → (Av1) browser_viewsourceprefs.js: Use "about:mozilla", instead of "about:robots", to support non-Firefox applications [Checked in: Comments 3 and 6]
status-firefox11: affected → fixed
status-firefox12: affected → fixed
Keywords: checkin-needed
Whiteboard: [c-n: to m-a and m-b] [perma-orange] → [perma-orange]
(Assignee)

Comment 7

6 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey-Aurora/1329891487.1329895867.22195.gz
OS X 10.6 comm-aurora debug test mochitest-other on 2012/02/21 22:18:07

firefox12: verified.

***

firefox11: SM log didn't report this failure. (Don't care further, atm.)
status-firefox12: fixed → verified
If "firefox11: SM log didn't report this as a failure", why was approval-mozilla-beta requested?
Whiteboard: [perma-orange] → [perma-orange][qa-]
(Assignee)

Comment 9

6 years ago
(In reply to Jared Wein [:jaws] from comment #8)
> If "firefox11: SM log didn't report this as a failure", why was
> approval-mozilla-beta requested?

In short: "broken" log should not prevent test fix.
(Assignee)

Comment 10

6 years ago
(In reply to Serge Gautherie (:sgautherie) from comment #7)
> firefox11: SM log didn't report this failure. (Don't care further, atm.)

(SM log is now fixed.)

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey-Beta/1330246820.1330252359.8062.gz&fulltext=1
Linux comm-beta debug test mochitest-other on 2012/02/26 01:00:20
{
INFO TEST-END | chrome://mochitests/content/browser/toolkit/components/viewsource/test/browser/browser_viewsourceprefs.js | finished in 3525ms
}

firefox11: verified.
status-firefox11: fixed → verified
You need to log in before you can comment on or make changes to this bug.