If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox not printing full web page when DIV tag spans more than one page.

RESOLVED DUPLICATE of bug 534182

Status

()

Core
Printing: Output
RESOLVED DUPLICATE of bug 534182
6 years ago
a year ago

People

(Reporter: retierney@cox.net, Unassigned)

Tracking

1.9.0 Branch
x86_64
All
Points:
---

Firefox Tracking Flags

(firefox50 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Build ID: 20120215223356

Steps to reproduce:

Windows 7 SP1 and Firefox 10.0.2. 

Open web page http://windows.microsoft.com/en-US/windows-vista/Connect-to-another-computer-using-Remote-Desktop-Connection.

Expand the "Show all" link at the bottom.

Do "Print Preview".


Actual results:

In "Print Preview" only one page shows up. If you scale down to 40%, all of the text shows up on one page.


Expected results:

All of the text should appear across two pages. It works in IE9.

See https://support.mozilla.org/questions/919941#answer-312579. 

All of the text is contained within several nested DIV tags. I confirmed this by right clicking and selecting "Inspect Element" and by inspecting the HTML source. I also inspected the CSS source. This particular CSS file is common across "windows.microsoft.com", so all of the web pages under this domain exhibit the same behavior.
(Reporter)

Comment 1

6 years ago
Oh, I didn't see anything in the CSS file that could be causing the problem, but have no experience with CSS and HTML, but I am a computer programmer and I learn very quickly. Thanks...

Updated

6 years ago
Component: Untriaged → Printing: Output
Product: Firefox → Core
QA Contact: untriaged → printing

Comment 2

6 years ago
Created attachment 598901 [details]
sample html

Comment 3

6 years ago
Confirmed 
http://hg.mozilla.org/mozilla-central/rev/561771f01881
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0a1) Gecko/13.0a1 Firefox/13.0a1 ID:20120220031231
http://hg.mozilla.org/mozilla-central/rev/0a7410527788
Mozilla/5.0 (X11; Linux i686; rv:13.0) Gecko/13 Firefox/13.0a1 ID:20120220074932
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All

Updated

a year ago
See Also: → bug 1283642

Comment 4

a year ago
Last Good: 2007-01-27-04
First Bad: 2007-01-28-04

Triggered by: Bug 9458
Blocks: 9458
status-firefox50: --- → affected
Version: 10 Branch → 1.9.0 Branch
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 534182
You need to log in before you can comment on or make changes to this bug.