If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Layout engine does not paint when there is no content

VERIFIED DUPLICATE of bug 5569

Status

()

Core
Layout
P3
normal
VERIFIED DUPLICATE of bug 5569
19 years ago
9 years ago

People

(Reporter: locka, Assigned: Kevin McCluskey (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
I am using the layout engine in the ActiveX control. It is possible to write an
application that instantiates my control in a dialog but only navigates
somewhere when the user clicks on a button.

Until the button is clicked, the layout engine sitting in the contol is in a
"created and visible but not showing any HTML content" state. It does not
attempt to paint itself at all in this state meaning the window becomes dirty as
windows are moved around over the top of it.

Would it be possible for the layout engine to paint itself a solid colour when
in this state?

Updated

19 years ago
Assignee: rickg → kmcclusk

Comment 1

19 years ago
Kevin -- I think we need a backstop renderer. If the page is empty (or no
windows are open) perhaps the main window should render a background.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M9
(Assignee)

Comment 2

19 years ago
The problem is there isn't any document so there isn't any frame around to paint
the background. We should probably give the webshell a chance to look at paint
events. If the webshell see's that there isn't a document loaded it can paint
and consume the paint event. If there is a document it should do nothing and the
normal. The default background color should come from the presentation context.
A presentation context factory would be provided to the webshell so that the
embedding app could change what the background initial background color.
(Assignee)

Updated

18 years ago
Target Milestone: M9 → M10
(Assignee)

Comment 3

18 years ago
Moving to M10
(Assignee)

Updated

18 years ago
Target Milestone: M10 → M11
(Assignee)

Comment 4

18 years ago
Moving to M11
(Assignee)

Updated

18 years ago
Target Milestone: M11 → M12
(Assignee)

Comment 5

18 years ago
Moving to M12
(Assignee)

Updated

18 years ago
Target Milestone: M12 → M13
(Assignee)

Comment 6

18 years ago
Moving to M13
I'm guessing this would also solve the problem with frames having undefined
content before they have their document loaded - right?
(Assignee)

Updated

18 years ago
Target Milestone: M13 → M15
(Assignee)

Comment 8

18 years ago
Moving to M15
(Assignee)

Comment 9

18 years ago

*** This bug has been marked as a duplicate of 5569 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Updated

18 years ago
Keywords: verifyme

Comment 10

18 years ago
Verified dupe.
Status: RESOLVED → VERIFIED

Updated

9 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.