on the tegra platform while running robocop unittests we seem to hit OOM very frequently

RESOLVED DUPLICATE of bug 731637

Status

()

RESOLVED DUPLICATE of bug 731637
7 years ago
7 years ago

People

(Reporter: jmaher, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 -)

Details

(Whiteboard: [android][tegra][android_tier_1])

(Reporter)

Description

7 years ago
this is causing us to not test properly, here is an example from logcat:

W/dalvikvm( 7595): threadid=1: thread exiting with uncaught exception (group=0x4001d820)
E/AndroidRuntime( 7595): FATAL EXCEPTION: main
E/AndroidRuntime( 7595): java.lang.OutOfMemoryError: bitmap size exceeds VM budget
E/AndroidRuntime( 7595): 	at android.graphics.BitmapFactory.nativeDecodeStream(Native Method)
E/AndroidRuntime( 7595): 	at android.graphics.BitmapFactory.decodeStream(BitmapFactory.java:459)
E/AndroidRuntime( 7595): 	at android.graphics.BitmapFactory.decodeResourceStream(BitmapFactory.java:323)
E/AndroidRuntime( 7595): 	at android.graphics.drawable.Drawable.createFromResourceStream(Drawable.java:697)
E/AndroidRuntime( 7595): 	at android.graphics.drawable.Drawable.createFromStream(Drawable.java:657)
E/AndroidRuntime( 7595): 	at org.mozilla.gecko.AwesomeBarTabs$AwesomeBarCursorAdapter.getDrawableFromDataURI(AwesomeBarTabs.java:596)
E/AndroidRuntime( 7595): 	at org.mozilla.gecko.AwesomeBarTabs$AwesomeBarCursorAdapter.bindSearchEngineView(AwesomeBarTabs.java:623)
E/AndroidRuntime( 7595): 	at org.mozilla.gecko.AwesomeBarTabs$AwesomeBarCursorAdapter.getView(AwesomeBarTabs.java:585)
E/AndroidRuntime( 7595): 	at android.widget.AbsListView.obtainView(AbsListView.java:1294)
E/AndroidRuntime( 7595): 	at android.widget.ListView.measureHeightOfChildren(ListView.java:1198)
E/AndroidRuntime( 7595): 	at android.widget.ListView.onMeasure(ListView.java:1109)
E/AndroidRuntime( 7595): 	at android.view.View.measure(View.java:8171)
E/AndroidRuntime( 7595): 	at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:3132)
E/AndroidRuntime( 7595): 	at android.widget.FrameLayout.onMeasure(FrameLayout.java:245)
E/AndroidRuntime( 7595): 	at android.view.View.measure(View.java:8171)
E/AndroidRuntime( 7595): 	at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:3132)
E/AndroidRuntime( 7595): 	at android.widget.LinearLayout.measureChildBeforeLayout(LinearLayout.java:1012)
E/AndroidRuntime( 7595): 	at android.widget.LinearLayout.measureVertical(LinearLayout.java:381)
E/AndroidRuntime( 7595): 	at android.widget.LinearLayout.onMeasure(LinearLayout.java:304)
E/AndroidRuntime( 7595): 	at android.view.View.measure(View.java:8171)
E/AndroidRuntime( 7595): 	at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:3132)
E/AndroidRuntime( 7595): 	at android.widget.FrameLayout.onMeasure(FrameLayout.java:245)
E/AndroidRuntime( 7595): 	at android.view.View.measure(View.java:8171)
E/AndroidRuntime( 7595): 	at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:3132)
E/AndroidRuntime( 7595): 	at android.widget.LinearLayout.measureChildBeforeLayout(LinearLayout.java:1012)
E/AndroidRuntime( 7595): 	at android.widget.LinearLayout.measureVertical(LinearLayout.java:381)
E/AndroidRuntime( 7595): 	at android.widget.LinearLayout.onMeasure(LinearLayout.java:304)
E/AndroidRuntime( 7595): 	at android.view.View.measure(View.java:8171)
E/AndroidRuntime( 7595): 	at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:3132)
E/AndroidRuntime( 7595): 	at android.widget.FrameLayout.onMeasure(FrameLayout.java:245)
E/AndroidRuntime( 7595): 	at android.view.View.measure(View.java:8171)
E/AndroidRuntime( 7595): 	at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:3132)
E/AndroidRuntime( 7595): 	at android.widget.FrameLayout.onMeasure(FrameLayout.java:245)
E/AndroidRuntime( 7595): 	at android.view.View.measure(View.java:8171)
E/AndroidRuntime( 7595): 	at android.view.ViewRoot.performTraversals(ViewRoot.java:801)
E/AndroidRuntime( 7595): 	at android.view.ViewRoot.handleMessage(ViewRoot.java:1727)
E/AndroidRuntime( 7595): 	at android.os.Handler.dispatchMessage(Handler.java:99)
E/AndroidRuntime( 7595): 	at android.os.Looper.loop(Looper.java:123)
E/AndroidRuntime( 7595): 	at org.mozilla.gecko.GeckoApp$34.run(GeckoApp.java:1807)
E/AndroidRuntime( 7595): 	at android.os.Handler.handleCallback(Handler.java:587)
E/AndroidRuntime( 7595): 	at android.os.Handler.dispatchMessage(Handler.java:92)
E/AndroidRuntime( 7595): 	at android.os.Looper.loop(Looper.java:123)
E/AndroidRuntime( 7595): 	at android.app.ActivityThread.main(ActivityThread.java:4627)
E/AndroidRuntime( 7595): 	at java.lang.reflect.Method.invokeNative(Native Method)
E/AndroidRuntime( 7595): 	at java.lang.reflect.Method.invoke(Method.java:521)
E/AndroidRuntime( 7595): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:868)
E/AndroidRuntime( 7595): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:626)
E/AndroidRuntime( 7595): 	at dalvik.system.NativeStart.main(Native Method)
W/ActivityManager( 1027): Error in app org.mozilla.fennec_jmaher running instrumentation ComponentInfo{org.mozilla.roboexample.test/android.test.InstrumentationTestRunner}:
W/ActivityManager( 1027):   java.lang.OutOfMemoryError
W/ActivityManager( 1027):   java.lang.OutOfMemoryError: bitmap size exceeds VM budget
D/AndroidRuntime( 7587): Shutting down VM

Comment 1

7 years ago
This *might* be related on "talos robocop" not working either.
(Reporter)

Comment 2

7 years ago
bug 731637 is a bug we can fix related to OOM and robocop.  That bug affects unittests and talos, but there are other issues with talos as well
(Reporter)

Updated

7 years ago
Whiteboard: [android][tegra][android_tier_1]
blocking-fennec1.0: --- → -
(Reporter)

Comment 3

7 years ago
we might be able to close this bug.  I haven't seen OOM errors for a while now.
Resolving; reopen if needed.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 731637
You need to log in before you can comment on or make changes to this bug.