Table heights get false with linked images

VERIFIED DUPLICATE of bug 5821

Status

()

P3
normal
VERIFIED DUPLICATE of bug 5821
20 years ago
19 years ago

People

(Reporter: kairo, Assigned: buster)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
I use a lot of tables with defined cell/line heights and images in those cells with the same height as the table. When such an image is a link, the line height is increased without any reason!

I made a test-document to narrow and show that problem:

--------------------- moztest.html -----------------------------------
<html>
<head>
   <title>Mozilla test</title>
</head>
<body>

below is table with link:<br>

 <table BORDER=0 CELLSPACING=0 CELLPADDING=0 COLS=1 WIDTH="100%" >
   <tr height="20">
    <td bgcolor="#6000CF"><a href="test.html">
    <img SRC="testpic1.gif" BORDER=0 height=20 width=15>
    </a></td>
   </tr>
 </table>

below is table without link:<br>

 <table BORDER=0 CELLSPACING=0 CELLPADDING=0 COLS=1 WIDTH="100%" >
   <tr height="20">
    <td bgcolor="#6000CF">
    <img SRC="testpic1.gif" BORDER=0 height=20 width=15></td>
   </tr>
 </table>

</body>
</html>
--------------------- EOF -----------------------------------

"bgcolor" is used to show the size of the table. In the first case (with link) the table size showed is incorrect, in the second case (without link) it's correct.
Bug viewed using Raptor/viewer.exe/win32 of 1999-05-26

Updated

20 years ago
Assignee: karnaze → kipp

Comment 1

20 years ago
The table cell's area frame when it contains <a> thinks it needs to be bigger
than it should. I would mark this as a duplicate of bug 5900, but I viewed the
test case there and didn't see the problem.
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → DUPLICATE
Mozilla is acting correctly. Use the CSS "vertical-align" property to override
the CSS line box model.

*** This bug has been marked as a duplicate of 5821 ***

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 3

20 years ago
Verified dup of #5821
You need to log in before you can comment on or make changes to this bug.