If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

HTML Table column/cell width update regression

RESOLVED DUPLICATE of bug 735579

Status

()

Core
Layout: Tables
RESOLVED DUPLICATE of bug 735579
6 years ago
6 years ago

People

(Reporter: r.i.k, Unassigned)

Tracking

({regression, reproducible, xhtml})

10 Branch
x86
All
regression, reproducible, xhtml
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 599170 [details]
HTML + Javascript testcase

User Agent: Mozilla/5.0 (X11; Linux i686; rv:10.0.1) Gecko/20100101 Firefox/10.0.1
Build ID: 20120208060813

Steps to reproduce:

I build a TABLE with CSS "table-layout: fixed", contained in a DIV with fixed-height and scroll overflow. Each cell (ie.TD element) have CSS "white-space: nowrap", "overflow: hidden" and "text-overflow: ellipsis" (CSS3)

This bug is similar to #451876, but this last one is too old to be reopened, and the current one only applies to Firefox 10 (Win/Linux), as there's no trouble in Firefox 9 (Win/Linux).


Actual results:

When using javascript to modify columns widths (ie. COL elements), the rendered cells (related to the modified columns) is not correct.

In the supplied testcase, press first link, then second link, and then scroll the table.
The column (COL element) has been correctly resized, the cell edges did not align (see the TD background color for a visual proof).


Expected results:

The cells should have been aligned with their related column (left|right) edge.
(Reporter)

Updated

6 years ago
Keywords: regression, reproducible, xhtml
See Also: → bug 451876

Updated

6 years ago
Attachment #599170 - Attachment mime type: text/plain → text/html

Comment 1

6 years ago
Regression window:
Works:
http://hg.mozilla.org/mozilla-central/rev/60e86b847759
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20110929 Firefox/10.0a1 ID:20110929122038
Fails:
http://hg.mozilla.org/mozilla-central/rev/af3668a89015
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20110929 Firefox/10.0a1 ID:20110929141938
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=60e86b847759&tochange=af3668a89015


In local build
Last Good : 34f184d2a6f8
First Bad : 00f422b2cf36

Triggered by:
00f422b2cf36	Ehsan Akhgari — Bug 10209 - Part 6: Implement the CSS "containing block" concept correctly as a binary relation, as opposed to a unary relation; r=bzbarsky
Blocks: 10209
Status: UNCONFIRMED → NEW
Component: Untriaged → Layout: Tables
Ever confirmed: true
OS: Linux → All
Product: Firefox → Core
QA Contact: untriaged → layout.tables
Created attachment 599449 [details]
Simpler testcase; part of a reftest pair
Created attachment 599450 [details]
Reference for the reftest pair
Making table rows not be absolute containing blocks does NOT help here.

Mats, any idea what's going on?

Note that the fixed-height block containing the table _does_ seem to be necessary, by the way.
Hmm, I can't repro on trunk.  Is this fixed?
Yep.  This looks like a dup of bug 735579 (complete with fixed-height div); that bug has a clear explanation of what was going on here.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 735579
Is it worth to create a reftest based on this?  (I can do that if you want)
I checked one in in bug 735579, so probably no need for a second one.
You need to log in before you can comment on or make changes to this bug.