Closed Bug 729139 Opened 8 years ago Closed 7 years ago

Sign not dropped from negative arc radiis

Categories

(Core :: SVG, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla18

People

(Reporter: cork, Assigned: longsonr)

References

()

Details

Attachments

(2 files, 1 obsolete file)

Attached image testcase
According to the spec for out-of-range parameters[1] negative radiis should drop there sign. Firefox doesn't do this and instead drops the arc.

In the attached testcase the left arc should look the same as the right.

[1] http://www.w3.org/TR/SVG11/implnote.html#ArcImplementationNotes
While the implementation notes state that negative radius values should be handled (ie, set by the DOM), the BNF for path data states that only non-negative numbers are allowed in the attribute:

http://www.w3.org/TR/SVG/paths.html#PathDataBNF
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 325912
IE, Chrome, Safari and Opera all seem to accept the negative radius in the path data.  I think we should accept it too and amend the spec.
Yeah, I think that's what we should do.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Any update on this?

As far as I can tell there's no response to the w3 issue.
It's clearly the right thing to do, so I just made the change in the spec: https://svgwg.org/svg2-draft/paths.html#PathDataBNF
Assignee: nobody → longsonr
Attached patch patch (obsolete) — Splinter Review
Attachment #665367 - Flags: review?(jwatt)
Attachment #665367 - Flags: review?(jwatt) → review+
Just noticed that arcs were the only user of ParseNonNegativeNumber so the method itself can go.
Attachment #665367 - Attachment is obsolete: true
Attachment #666182 - Flags: review?(jwatt)
Attachment #666182 - Flags: review?(jwatt) → review+
Duplicate of this bug: 325912
https://hg.mozilla.org/mozilla-central/rev/da4714c5e564
Status: REOPENED → RESOLVED
Closed: 8 years ago7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
You need to log in before you can comment on or make changes to this bug.