If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

JS_Enumerate fails to enumerate properties of a "new Error()" object

RESOLVED DUPLICATE of bug 724768

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 724768
6 years ago
6 years ago

People

(Reporter: Franck, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
var err = new Error();
for ( var p in err ) {
  //err.hasOwnProperty(p);
}
...
JS_Enumerate(cx, JSVAL_TO_OBJECT(the_err_value))->length == 0

However if err.hasOwnProperty(p) is uncommented, ->length is 2 (fileName, lineNumber).
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 724768
You need to log in before you can comment on or make changes to this bug.