Last Comment Bug 729427 - Incremental GC should mark filenames of newly allocated scripts
: Incremental GC should mark filenames of newly allocated scripts
Status: RESOLVED FIXED
[qa-]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla13
Assigned To: Igor Bukanov
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks: IncrementalGC
  Show dependency treegraph
 
Reported: 2012-02-21 23:56 PST by Igor Bukanov
Modified: 2012-05-10 12:13 PDT (History)
65 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed


Attachments
v1 (2.37 KB, patch)
2012-02-23 10:46 PST, Igor Bukanov
wmccloskey: review+
Details | Diff | Splinter Review

Description Igor Bukanov 2012-02-21 23:56:07 PST
See bug #641025 comment 124:
Comment 1 [PTO to Dec5] Bill McCloskey (:billm) 2012-02-22 17:55:16 PST
We also need to mark whenever we look up a filename in the hashtable, since it's effectively a weak pointer.
Comment 2 Igor Bukanov 2012-02-22 22:43:01 PST
(In reply to Bill McCloskey (:billm) from comment #1)
> We also need to mark whenever we look up a filename in the hashtable, since
> it's effectively a weak pointer.

My plan is to mark newly incremental filename entries under the incremental GC. The rest of cases should be covered by normal marking as the filename is never overwritten. But eventually I want to either remove them or at least turn them into atoms. My initial measurements shows that filename strings are atoms in about 10-15% cases so turning mostly ascii string into UTF16 char array + JSString header should not bloat memory match...
Comment 3 Igor Bukanov 2012-02-23 10:46:44 PST
Created attachment 600089 [details] [diff] [review]
v1
Comment 4 [PTO to Dec5] Bill McCloskey (:billm) 2012-02-23 11:08:24 PST
Comment on attachment 600089 [details] [diff] [review]
v1

Thanks.
Comment 6 Marco Bonardo [::mak] 2012-02-24 02:33:15 PST
https://hg.mozilla.org/mozilla-central/rev/f3b449b1eea2

Note You need to log in before you can comment on or make changes to this bug.