Firefox not scaling images correctly

RESOLVED DUPLICATE of bug 486918

Status

()

Core
ImageLib
RESOLVED DUPLICATE of bug 486918
6 years ago
3 years ago

People

(Reporter: Murray, Unassigned)

Tracking

10 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Build ID: 20120215223356

Steps to reproduce:

An original jpg image was scaled down to fit inside a particular screen area. 
I tested this in IE, Safari, Chrome and Firefox, side-by-side on the same computer.


Actual results:

After scaling the image appears correctly in IE, Safari and Chrome. Firefox displays a pixelated version of the image - significantly lesser quality than the original.

I took this problem to the Google groups firefox support forum, you can see it here:
https://groups.google.com/forum/?fromgroups#!topic/mozilla.support.firefox/F_m-IhczAts

An extract from my forum post summarised the problem quite well - it follows now:

Now to the others.... just to prove this has absolutely nothing to do with HTML validation standards or DOCTYPE blah blah blah... I copied this image into a public location and then displayed this in all three browsers:

http://focus-computing.com.au/cabinet-plain-jpg.jpg

I was surprised but happy - they are all the same.

Okay, let's wrap some basic html (and yes, you can read the URL and use it, it is public, however it was modified to the version below).  Loaded this to all three browsers, and the result:

http://focus-computing.com.au/cabinet-plain-html.jpg

Again, it was the same.  Doubly surprised! So I checked the original and there was some scaling going on, so I added height and width to the <img> and reloaded all three browsers:

http://focus-computing.com.au/cabinet-html-scaled.jpg

Voila'  Safari and Chrome look like the original appropriately scaled.  Firefox does it's pixelating thing. 


Expected results:

The image should appear scaled as it does in the other browsers without the loss in quality.

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 486918
(Reporter)

Comment 2

6 years ago
It does look the same.... which really begs the question why isn't it fixed?  486918 was reported nearly 3 years back and discussed extensively in 2010.  We are now in 2012 !  I downloaded ff 10.0.2 just yesterday to test this and it clearly is no better than it was 3 years ago.

If it ain't working it isn't resolved!
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Murray:

This *IS* a duplicate bug. It exhibits the same behavior as exhibited in bug 486918. 

Simply because it hasn't been fixed yet does not mean that a second bug should be opened.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 486918
You need to log in before you can comment on or make changes to this bug.