If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

mozglue/linker/szip.cpp compile error on Mac: ‘posix_fallocate’ was not declared

RESOLVED FIXED in mozilla13

Status

()

Core
mozglue
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: cpeterson, Assigned: glandium)

Tracking

Trunk
mozilla13
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Compiling m-c on Mac gives the following compile error:

/mozilla/inbound3/mozglue/linker/szip.cpp: In function ‘int main(int, char**)’:
/mozilla/inbound3/mozglue/linker/szip.cpp:70: error: ‘posix_fallocate’ was not declared in this scope

glandium's workaround patch:
http://pastebin.mozilla.org/1490507
(Reporter)

Updated

6 years ago
Summary: mozglue compile error on Mac: linker/szip.cpp: ‘posix_fallocate’ was not declared mozglue compile error on Mac: linker/szip.cpp: ‘posix_fallocate’ was not declared → mozglue/linker/szip.cpp compile error on Mac: ‘posix_fallocate’ was not declared mozglue/linker/szip.cpp compile error on Mac: ‘posix_fallocate’ was not declared
(Assignee)

Updated

6 years ago
Component: General → mozglue
Product: Firefox → Core
QA Contact: general → mozglue
(Assignee)

Updated

6 years ago
Assignee: nobody → mh+mozilla
Blocks: 686805
(Assignee)

Comment 1

6 years ago
Created attachment 599693 [details] [diff] [review]
Use ftruncate in szip instead of posix_fallocate

We could use the equivalent of posix_fallocate for mac, but since the file is filled sequentially anyways, and since it's a host program, it's not worth bothering.
Attachment #599693 - Flags: review?(taras.mozilla)

Comment 2

6 years ago
Comment on attachment 599693 [details] [diff] [review]
Use ftruncate in szip instead of posix_fallocate

I don't think I need to review trivial changes like this.
Attachment #599693 - Flags: review?(taras.mozilla) → review+
Duplicate of this bug: 729641
Inbound:

https://hg.mozilla.org/integration/mozilla-inbound/rev/775aeed72aef

Someone should probably land this directly on m-c.

Comment 5

6 years ago
https://hg.mozilla.org/mozilla-central/rev/775aeed72aef
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla13
You need to log in before you can comment on or make changes to this bug.