Closed Bug 729705 Opened 8 years ago Closed 8 years ago

Seeking with video controls jumps to end of video

Categories

(Firefox for Android :: General, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 657791

People

(Reporter: wesj, Unassigned)

References

()

Details

Tapping on the scrubber will seek to a position for a second and then immediately skip to the end of the video. Still trying to debug why.


I haven't been able to find any problems with the controls themselves that cause this. We do pause and play the video in quick succession before the seek happens because of how we fire click events: http://mxr.mozilla.org/mozilla-central/source/toolkit/content/widgets/videocontrols.xml#167 (this is different than what happens on desktop). Shortly after the controls receive a timeupdate event from the video itself that causes them to jump to the end.
hmm... this doesn't affect all videos, but does affect the one in the url:

http://mxr.mozilla.org/mozilla-central/source/toolkit/content/widgets/videocontrols.xml#167
The webm file doesn't have any cues; it doesn't have an index of keyframes, so our webm code can't seek in it.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 657791
cc'ing nhirata just to make sure he knows his webm file has issues.
You need to log in before you can comment on or make changes to this bug.