Closed Bug 729759 Opened 8 years ago Closed 7 years ago

nsBlockFrame.cpp:1585:59: warning: suggest parentheses around ‘&&’ within ‘||’

Categories

(Core :: Layout: Block and Inline, defect, trivial)

x86_64
Linux
defect
Not set
trivial

Tracking

()

RESOLVED DUPLICATE of bug 799407

People

(Reporter: mats, Unassigned)

References

(Blocks 1 open bug)

Details

This is a new warning when compiling with GCC on Linux.

  1576  bool static inline IsAlignedLeft(const PRUint8 aAlignment,
  1577                                   const PRUint8 aDirection,
  1578                                   const PRUint8 aUnicodeBidi)
  1579  {
  1580    return (NS_STYLE_TEXT_ALIGN_LEFT == aAlignment ||
  1581            ((NS_STYLE_TEXT_ALIGN_DEFAULT == aAlignment &&
  1582              NS_STYLE_DIRECTION_LTR == aDirection) ||
  1583             (NS_STYLE_TEXT_ALIGN_END == aAlignment &&
  1584              NS_STYLE_DIRECTION_RTL == aDirection)) &&
  1585            !(NS_STYLE_UNICODE_BIDI_PLAINTEXT & aUnicodeBidi));
  1586  }
Blocks: buildwarning
This seems to have been fixed in bug 799407, attachment 669856 [details] [diff] [review].
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 799407
You need to log in before you can comment on or make changes to this bug.