Horizontal line and table goes through table in right

RESOLVED DUPLICATE of bug 14984

Status

()

RESOLVED DUPLICATE of bug 14984
18 years ago
15 years ago

People

(Reporter: mkriz, Assigned: waterson)

Tracking

({qawanted, testcase})

Trunk
Future
x86
Windows 2000
qawanted, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; 0.8) Gecko/20010215
BuildID:    20010215

Horizontal line and table goes through table aligned in right. HTML source is
commented.

Reproducible: Always
Steps to Reproduce:
Show a page.
In strict mode that certainly looks like correct behavior... you have a
float:right table and a width:100% table and so naturally the boxes overlap...

In quirks mode, however, this seems to be wrong....

Comment 2

18 years ago
In quirks mode, using the html transitional 4 doctype, the layout of the page is 
the same as NS 4.7. The HR stops at the right floating table. The HTML 4 Final 
doctype provided in the test, renders the document in strict.
Created attachment 28523 [details]
testcase using HTML 3.2 doctype
The <hr> does render correctly in quirks mode.  The <table width="100%"> does
not....

Comment 5

18 years ago
Boris, what do you mean when you say the table is not rendered properly ? I 
looked at the table in both N4.7/N6 and it appears to render the table at 100%. 
It also overlaps the first table in both apps. Let me know, thanks....
Created attachment 28561 [details]
Mozilla build from 2001-03-23, linux.  rendering of testcase
Created attachment 28562 [details]
netscape 4.76, linux. Rendering of testcase
Comparing the two screenshots, it should be pretty clear how the rendering
differs....

Comment 9

18 years ago
I checked this originally in a Mac Build which showed the table render problem in 
both NS 4.7 and NS6 with the quirks mode. Your screen shots clearly show a 
difference. Changing status to confirm.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 10

18 years ago
Still happening in today's build on Windows 2000. Over to tables.
Component: Layout → HTMLTables
QA Contact: petersen → amar
Target Milestone: --- → mozilla1.0

Comment 11

18 years ago
*** Bug 77528 has been marked as a duplicate of this bug. ***
Created attachment 32871 [details]
The page source linking to the original site for resources
What is the quirks mode you all speak about?
I have a page that renders strange - one table is partially overlapped with
another (text of the table is on top, background in bottom). see attachment

Another problem is that overlapping tables loses content. Someone showed me the
W3C specification which isn't very clear for table and seems to be simply a
mistake for HR. 

One more problem is that left or right aligned table is placed below the other,
while centered or unspecified overlaps the small one which is a bit confusing.

Tried with 2001-05-01-21 on Linux

BTW: this is not only about tables, the same problem is with HR (improper component)
Basically, many currently existing pages depend on IE4 or NS4 bugs to display
correctly.  When rendered according to the standard they break horribly.  As a
result both IE 5 and Mozilla implement a bug-compatible "quirks mode" that is
triggered by pages that
a) Have no doctype
b) Have a HTML 2.0 or 3.2 doctype
c) Have an HTML 4.0 Transitional doctype
d) Have an HTML 4.01 Transitional doctype without the DTD URI.

The page you have attached is 4.01 Transitional with URI, so it is not rendered
in quirks mode. However, even in quirks mode the rendering is the same (tested
by removing the DTD).

I still believe this is correct:  a <table width="100%"> and a <table
float="right"> should overlap.  If you don't want that overlap, you would
probably be better served with:

<table style="width: auto; margin-right: whatever"> instead of width="100%",
where 'whatever' is the width of the floating table.

Hixie, what should we be doing here (ignoring for a moment that these are tables
-- for the purposes of this bug they are just block elements, I think).
Keywords: qawanted

Updated

18 years ago
Keywords: testcase
Adding the "testcase" keyword

Comment 16

18 years ago
Looks like a floater problem. Reassigning to waterson.
Assignee: karnaze → waterson
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
I can see two problems here:
-the elements overlap at all. IMO no elements should ever overlap unless
explicitly placed by some script or such. Avoiding overlaps would solve the
other problem as well. 
Overlaping tables could cause Mozilla to deliver worse browsing experience than
an older browser or just telnet. While you usually can read a HTML source, you
cant decompose what is overlapped on your screen.
-the overlapping is done wrong. The background of the left table goes under the
rigth table while text and hr go over it. 
Anyway, what is the rule for determining which table goes on top? This is
another reason why i think the standard (or your interpretationof the standard)
is flawed here.
(Assignee)

Updated

17 years ago
Target Milestone: mozilla1.1beta → Future

*** This bug has been marked as a duplicate of 14984 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.