New cache: unable to view results of POST to same URL

VERIFIED DUPLICATE of bug 73016

Status

()

--
critical
VERIFIED DUPLICATE of bug 73016
18 years ago
18 years ago

People

(Reporter: dave532, Assigned: darin.moz)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
UA: Mozilla/5.0 (X11; U; Linux 2.2.16 i686; en-US; 0.8.1) Gecko/20010315
(the Mozilla build with new cache enabled pointed to by www.mozillazine.org)
OS: Linux 2.2.16 (Red Hat Linux release 6.2)

Visiting the railtrack timetable at: http://212.87.65.227/bin/query.exe/en
brings up a timetable search form, submitting the form POST's the data to the
same URL:
<form ACTION="http://212.87.65.227/bin/query.exe/en" NAME=formular METHOD="POST">

Expected Result:
Data submitted to form, results of submission displayed.

Actual Result:
Unable to tell if data is actually submitted, but as the throbber is only active
for a short moment so I suspect it isn't. The page refreshes and the same page
as before is displayed. It looks like the browser is going to the cache and just
pulling the same copy of the URL.

Note:
Obviously I was online when I tried this, but switching to offline mode and
trying to submit the form produces the same result and no error message is
produced (expected: unable to submit form in offline mode). In the console you
are told the document was loaded successfully.

Steps to reproduce:
1. Use a build with new cache
2. Goto http://212.87.65.227/bin/query.exe/en
3. Enter some details
4. Click submit

Reproducable: always

Note: Works fine in builds using old cache on all platforms (fine on build ID:
2001031821 and all previous builds). Only tested with new cache under Linux.

I am accessing the web through a proxy server.

Comment 1

18 years ago
I can confirm this on the 2001032205 linux build.  Also I can confirm that the
Post is never submitted ( I checked my server logs, and the post never shows
up).  It would appear that the page is just re-pulled from the cache.

Scott
(Assignee)

Comment 2

18 years ago
Sounds like an HTTP bug.
Assignee: neeti → darin
Component: Networking: Cache → Networking: HTTP
(Assignee)

Comment 3

18 years ago
adding a comment
(Assignee)

Comment 4

18 years ago

*** This bug has been marked as a duplicate of 73016 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

18 years ago
Works fine now. Verified dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.