Add-ons can not be installed after installing an add-on requiring browser restart

RESOLVED DUPLICATE of bug 717904

Status

Fennec Graveyard
General
RESOLVED DUPLICATE of bug 717904
6 years ago
2 years ago

People

(Reporter: Andreea Pod, Unassigned)

Tracking

({regression})

Firefox 11
ARM
Android
regression

Details

Attachments

(1 attachment)

log
64.40 KB, text/plain
Details
(Reporter)

Description

6 years ago
Mozilla/5.0(Android; Mobile; rv:11.0) Gecko/11.0 Firefox/11.0 Fennec/11.0
Device: LG Optimus 2x (Android 2.2), Asus EEE Transformers (Android 3.2.1)

Steps to reproduce:
1. Go to Add-ons Manager
2. Install from Get "Add-ons" a recommend add-on that requires restart like "Bigger Text"

Expected results:
the add-on should appear in "Your Add-ons" section in Add-ons Manager

Actual results:
Add-on is not visible on "Your Add-ons" section and you are not able to install any another add-on.
(Reporter)

Comment 1

6 years ago
Created attachment 600025 [details]
log
(Reporter)

Updated

6 years ago
Summary: Add-ons can not be installed after → Add-ons can not be installed after installing an add-on requiring browser restart

Updated

6 years ago
status-firefox11: --- → affected
Tested Firefox 10, not affected. Issue introduced in 11's timeline.
status-firefox10: --- → unaffected
Keywords: regression, regressionwindow-wanted
Couple errors on restart:

E/GeckoConsole( 6492): [JavaScript Error: "ERROR addons.xpi: Failed to open database (1st attempt): [Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: resource://gre/modules/XPCOMUtils.jsm :: XPCU_serviceLambda :: line 232"  data: no]" {file: "resource://gre/modules/XPCOMUtils.jsm" line: 232}]

E/GeckoConsole( 6492): [JavaScript Error: "ERROR addons.xpi: Failed to open database (2nd attempt): TypeError: Services.storage is undefined" {file: "resource://gre/modules/XPIProvider.jsm" line: 4228}]

E/GeckoConsole( 6492): [JavaScript Error: "ERROR addons.xpi: Error during startup file checks, rolling back any database changes: TypeError: Services.storage is undefined" {file: "resource://gre/modules/XPIProvider.jsm" line: 4236}]

E/GeckoConsole( 6492): [JavaScript Error: "ERROR addons.xpi: Error creating statement rollbackSavepoint (ROLLBACK TO SAVEPOINT 'default')" {file: "resource://gre/modules/XPIProvider.jsm" line: 4591}]

E/GeckoConsole( 6492): [JavaScript Error: "ERROR addons.manager: Exception calling provider startup: TypeError: this.connection is undefined" {file: "resource://gre/modules/XPIProvider.jsm" line: 4588}]
And then on install attempt of a different add-on post restart:

I/GeckoAppJava( 6492): GeckoAppShell.alertsProgressListener_OnProgress
I/GeckoAppJava( 6492): - name = 'addons', progress = 2372 / 2372, text = ''

E/GeckoConsole( 6492): [JavaScript Error: "ERROR addons.repository: Failed to open database: TypeError: Services.storage is undefined" {file: "resource://gre/modules/AddonRepository.jsm" line: 1579}]

E/GeckoConsole( 6492): [JavaScript Error: "ERROR addons.repository: Error creating statement getAllAddons (SELECT internal_id, id, type, name, version, creator, creatorURL, description, fullDescription, developerComments, eula, iconURL, homepageURL, supportURL, contributionURL, contributionAmount, averageRating, reviewCount, reviewURL, totalDownloads, weeklyDownloads, dailyUsers, sourceURI, repositoryStatus, size, updateDate FROM addon)" {file: "resource://gre/modules/AddonRepository.jsm" line: 1715}]

E/GeckoConsole( 6492): [JavaScript Warning: "WARN addons.xpi: Download failed: TypeError: this.connection is undefined" {file: "resource://gre/modules/AddonRepository.jsm" line: 1571}]
The failures here basically say that Services.storage is broken during mobile startup. 

> E/GeckoConsole( 6492): [JavaScript Error: "ERROR addons.xpi: Failed to open
> database (1st attempt): [Exception... "Component returned failure code:
> 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]" 
> nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS
> frame :: resource://gre/modules/XPCOMUtils.jsm :: XPCU_serviceLambda :: line
> 232"  data: no]" {file: "resource://gre/modules/XPCOMUtils.jsm" line: 232}]

This is being thrown by basically the code:

Cc["@mozilla.org/storage/service;1"].getService(Ci.mozIStorageService);

Which suggests something broken in xpcom land.

Oh, I said much the same in bug 717904 comment 4, this is probably a straight dupe of that.

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 717904
status-firefox10: unaffected → ---
status-firefox11: affected → ---
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.