Maple: Simplify paint suppression code

RESOLVED DUPLICATE of bug 732564

Status

()

RESOLVED DUPLICATE of bug 732564
7 years ago
7 years ago

People

(Reporter: BenWa, Assigned: kats)

Tracking

(Blocks: 1 bug)

unspecified
x86
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-fennec1.0 beta+)

Details

(Reporter)

Description

7 years ago
We need to simplify the paint suppression code. Currently we do paint suppression in 3 different places, crossing the android bridge, calling back into JS and a whole bunch of spaghetti code.
(Reporter)

Comment 1

7 years ago
First goal is to remove metadataProvider->PaintingSuppressed.

From my discussion with Ehsan we can remove this making nsPresShell aware of the paint supression for meta viewport.
Keywords: fennecnative-betablocker
blocking-fennec1.0: --- → beta+
Taking this, one of my patches handles this.
Assignee: nobody → bugmail.mozilla
.. and that patch will go on bug 732564.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 732564
You need to log in before you can comment on or make changes to this bug.