Closed Bug 730189 Opened 10 years ago Closed 10 years ago

Bluetooth tethering not considered a valid Internet connection by "Set Up Sync"

Categories

(Firefox for Android Graveyard :: Android Sync, defect, P2)

ARM
Android
defect

Tracking

(firefox14 verified, firefox15 verified, blocking-fennec1.0 +)

VERIFIED FIXED
mozilla13
Tracking Status
firefox14 --- verified
firefox15 --- verified
blocking-fennec1.0 --- +

People

(Reporter: ravi_n+mozilla, Assigned: liuche)

Details

User Agent: Mozilla/5.0 (Android; Tablet; rv:12.0a2) Gecko/12.0a2 Firefox/12.0a2
Build ID: 20120223042013

Steps to reproduce:

I tried to set up Firefox Sync on my ASUS Transformer (running ICS) while tethered to my phone via Bluetooth.


Actual results:

Set Up Sync said I didn't have an Internet connection (even though I am using that connection to file this bug).


Expected results:

I should have been able to set up Firefox Sync just as if I had been connected via WiFi.
Are you able to create any other Android accounts and sync while tethered? Have you also tried Nightly (http://nightly.mozilla.org) for Android?
Good catch. We only check for wifi and mobile as data connections.

We should probably be checking for <http://developer.android.com/reference/android/net/ConnectivityManager.html#EXTRA_NO_CONNECTIVITY> instead.
Status: UNCONFIRMED → NEW
Component: General → Android Sync
Ever confirmed: true
Product: Fennec Native → Mozilla Services
QA Contact: general → android-sync
Version: Firefox 12 → unspecified
tracking-fennec: --- → ?
OS: Other → Android
Priority: -- → P2
Hardware: Other → ARM
(In reply to Aaron Train [:aaronmt] from comment #1)
> Are you able to create any other Android accounts and sync while tethered?
> Have you also tried Nightly (http://nightly.mozilla.org) for Android?

1. Yes. I was rebuilding my Transformer from scratch after the ICS update and I successfully added and synced my Google account while tethered over Bluetooth.

2. I just downloaded Nightly and I have the same problem there.
(In reply to Richard Newman [:rnewman] from comment #2)
> Good catch. We only check for wifi and mobile as data connections.
> 
> We should probably be checking for
> <http://developer.android.com/reference/android/net/ConnectivityManager.
> html#EXTRA_NO_CONNECTIVITY> instead.

Thanks. I only caught it because the ICS ROM I'm running on my phone doesn't support WiFi tethering, which made me switch to Bluetooth. Along those lines, I wonder what would happen if someone got a device (probably a tablet, I'd guess) online with a USB Ethernet adapter.
We will also fail to spot WiMax, Ethernet, and dial-up… unless you _also_ have wifi or GPRS/EDGE/3G, of course.
Assignee: nobody → liuche
blocking-fennec1.0: --- → +
Status: NEW → ASSIGNED
this changeset has been assigned to this bug, though this bug doesn't even have an attached patch. So whoever knows what's up please fix it.

https://hg.mozilla.org/mozilla-central/rev/d9460c5f6415
mak: Android Sync development takes place on GitHub, and changes are landed directly on inbound after being reviewed and merged upstream. When you're sheriffing, you won't see patch attachments.

Thanks for checking!
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla13
ravi, please verify this against a nighty build. thanks.
Android Sync is working as expected if the Internet connection is set via Bluetooth tethering. Closing bug as verified fixed on:

Firefox 15.0a1 (2012-05-29)
Firefox 14.0a2 (2012-05-29)

Device: Galaxy Nexus
OS: Android 4.0.2
Status: RESOLVED → VERIFIED
Product: Mozilla Services → Android Background Services
tracking-fennec: ? → ---
Product: Android Background Services → Firefox for Android
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.