Port |Bug 698381 - Node.cloneNode's deep parameter should be optional (default to true)| to comm-central

VERIFIED FIXED in Thunderbird 13.0

Status

MailNews Core
Import
P1
blocker
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: sgautherie, Assigned: sgautherie)

Tracking

Trunk
Thunderbird 13.0
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=ThunderbirdTrunk/1330051258.1330056057.10491.gz
WINNT 5.2 comm-central leak test build on 2012/02/23 18:40:58
{
nsEudoraEditor.cpp

e:/buildbot/win32-comm-central-bloat/build/mailnews/import/eudora/src/nsEudoraEditor.cpp(468) : error C2511: 'nsresult nsEudoraHTMLImageElement::CloneNode(bool,nsIDOMNode **)' : overloaded member function not found in 'nsEudoraHTMLImageElement'

        e:\buildbot\win32-comm-central-bloat\build\mailnews\import\eudora\src\nsEudoraEditor.h(65) : see declaration of 'nsEudoraHTMLImageElement'
}
(Assignee)

Comment 1

6 years ago
Most likely caused by bug 698381.
Depends on: 698381
(Assignee)

Updated

6 years ago
(Assignee)

Comment 2

6 years ago
Created attachment 600324 [details] [diff] [review]
(Av1) Add new 'aOptionalArgc' parameter to CloneNode()
[Checked in: Comment 2]

Asking for post-push review of
http://hg.mozilla.org/comm-central/rev/614ca8370fac
Attachment #600324 - Flags: review?(mbanner)
(Assignee)

Updated

6 years ago
Assignee: nobody → sgautherie.bz
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: in-testsuite-
Keywords: regression
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Attachment #600324 - Attachment description: (Av1) Add new 'aOptionalArgc' parameter to CloneNode() → (Av1) Add new 'aOptionalArgc' parameter to CloneNode() [Checked in: Comment 2]
(Assignee)

Updated

6 years ago
Summary: nsEudoraEditor.cpp fails to compile since "Thu Feb 23 18:35:54 2012 PST, Merge last win pgo-green changeset from m-i to m-c." → Port |Bug 698381 - Node.cloneNode's deep parameter should be optional (default to true)| to comm-central
(Assignee)

Comment 3

6 years ago
http://build.mozillamessaging.com/tinderboxpushlog/?tree=ThunderbirdTrunk&rev=614ca8370fac

V.Fixed
Status: RESOLVED → VERIFIED
Comment on attachment 600324 [details] [diff] [review]
(Av1) Add new 'aOptionalArgc' parameter to CloneNode()
[Checked in: Comment 2]

Thanks for fixing the bustage :-)
Attachment #600324 - Flags: review?(mbanner) → review+
You need to log in before you can comment on or make changes to this bug.