Closed Bug 730231 Opened 8 years ago Closed 8 years ago

incomplete attachment download (MS-Exchange 2010 IMAP)

Categories

(MailNews Core :: Networking: IMAP, defect)

x86_64
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 92111

People

(Reporter: uli.schellhaas, Unassigned)

Details

(Whiteboard: dupeme?)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Build ID: 20120215223356

Steps to reproduce:

Hello,

we are migrating Mailboxes from cyrus based imap4 to Exchange 2010.
We have 2 backend Servers and a frontend Server.
Mails with Attachments wont be downloaded fully, resulting in corrupt pdf's for example.


Actual results:

incomplete mail download. Other testet imap Clients like k-9 mail or claws-mail or outlook can do it error free.


Expected results:

complete mail download !

i saved a mail-sourcecode of an email from myself with 4 pictures attached. thunderbird shows 3 attachments, the 3rd is only halfe there.
Filesize of that windows-saved .txt is 514.248 Bytes
i deleted my inbox file several times, so TB should reload contents.
3 times mail was incomplete, 2 times it was complete.

like i said, other users (3 and counting up) have the issue too.
maybe some nic mtu issue or whatever ?
likely some duplicate:

    https://bugzilla.mozilla.org/show_bug.cgi?id=512693
    https://bugzilla.mozilla.org/show_bug.cgi?id=560346
    http://kb.wisc.edu/helpdesk/page.php?id=12472


however, if this helps users i would recommend Thunderbird to detect Exchange imap Serviers:

*   OK The Microsoft Exchange IMAP4 Service is ready

and set those values for themselves ?!?
Bug 92111 Comment #45 has a workaround which may resolve the problem. On Windows, go into Tools > Options > Advanced > General and click on Config Editor. There, enter fetch_by_chunks into the search bar of the preferences dialog and set all
mail.server.<whatever>.fetch_by_chunks to "false" by double-clicking on them. Usually you may only see mail.server.default.fetch_by_chunks unless a setting specific for a server was established (<whatever> = server#).
Component: General → Networking: IMAP
Product: Thunderbird → MailNews Core
QA Contact: general → networking.imap
Summary: incomplete attachment download → incomplete attachment download (MS-Exchange 2010 IMAP)
Whiteboard: dupeme?
Uli does that help ?
Hello,

thanks for the hint, we appllied the setting to 4 Clients, and are watching.
Are there by any chance ways to set this for all users ? Like send them an email to >click here< and whoops its changed ?

greetings
No :(
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 92111
You need to log in before you can comment on or make changes to this bug.