Crash @ js::GCMarker::processMarkStackTop

RESOLVED DUPLICATE of bug 719114

Status

()

--
critical
RESOLVED DUPLICATE of bug 719114
7 years ago
6 years ago

People

(Reporter: scoobidiver, Unassigned)

Tracking

({crash, regression})

13 Branch
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

7 years ago
It's a new crash signature that first appeared in 13.0a1/2012020 on Windows and 13.0a1/20120219 on Mac OS X.
The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=550779e6bab4&tochange=4d47329bb02e
The likely culprit is bug 641025.

Signature 	js::GCMarker::processMarkStackTop(js::SliceBudget&) More Reports Search
UUID	6b7ef8a1-52f6-46ca-b5a8-f909d2120224
Date Processed	2012-02-24 10:15:45
Uptime	34
Last Crash	11.7 weeks before submission
Install Age	1.6 days since version was first installed.
Install Time	2012-02-22 20:04:34
Product	Firefox
Version	13.0a1
Build ID	20120222031223
Release Channel	nightly
OS	Windows NT
OS Version	6.1.7601 Service Pack 1
Build Architecture	x86
Build Architecture Info	GenuineIntel family 6 model 42 stepping 7
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x7c4fd7e0
App Notes 	
AdapterVendorID: 0x1002, AdapterDeviceID: 0x9498, AdapterSubsysID: 22691787, AdapterDriverVersion: 8.632.1.2000
D3D10 Layers? D3D10 Layers-
D3D9 Layers? D3D9 Layers-
EMCheckCompatibility	True	
Total Virtual Memory	2147352576
Available Virtual Memory	1768087552
System Memory Use Percentage	54
Available Page File	2731278336
Available Physical Memory	960667648

Frame 	Module 	Signature [Expand] 	Source
0 	mozjs.dll 	js::GCMarker::processMarkStackTop 	js/src/jsgcmark.cpp:1069
1 	mozjs.dll 	js::GCMarker::drainMarkStack 	js/src/jsgcmark.cpp:1154
2 	mozjs.dll 	IncrementalGCSlice 	js/src/jsgc.cpp:3481
3 	mozjs.dll 	AutoCopyFreeListToArenas::AutoCopyFreeListToArenas 	js/src/jsgc.cpp:3431
4 	mozjs.dll 	GCCycle 	js/src/jsgc.cpp:3620
5 	nspr4.dll 	PR_EnterMonitor 	nsprpub/pr/src/threads/prmon.c:99
6 	mozjs.dll 	Collect 	js/src/jsgc.cpp:3683
7 	xul.dll 	nsDOMUIEvent::Release 	content/events/src/nsDOMTransitionEvent.cpp:76
8 	mozjs.dll 	js::GCSlice 	js/src/jsgc.cpp:3709
9 	mozjs.dll 	js::IncrementalGC 	js/src/jsfriendapi.cpp:156
10 	xul.dll 	nsXPConnect::Collect 	js/xpconnect/src/nsXPConnect.cpp:426
11 	KERNELBASE.dll 	ReleaseSemaphore 	

More reports at:
https://crash-stats.mozilla.com/report/list?signature=js%3A%3AGCMarker%3A%3AprocessMarkStackTop%28js%3A%3ASliceBudget%26%29
https://crash-stats.mozilla.com/report/list?signature=js%3A%3AGCMarker%3A%3AprocessMarkStackTop
Can we combine this with bug 719114? All that happened was that the function got a new parameter. It's possible that the crash rate when up a little, but it's really hard to tell with so little data.
(Reporter)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 719114
You need to log in before you can comment on or make changes to this bug.