unable to resolve virtual method 4068: Ljava/util/LinkedList;.push / .pop

VERIFIED FIXED in Firefox 13

Status

()

Firefox for Android
General
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: gbrown, Assigned: Margaret)

Tracking

Trunk
Firefox 13
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox13 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Running on Android 2.2.1 / Froyo, I get an exception when accessing the bookmarks list:

    I/ActivityManager( 3097): Starting activity: Intent { flg=0x40010000 cmp=org.mozilla.fennec_mozdev/org.mozilla.gecko.AwesomeBar (has extras) }
    I/GeckoApp(31191): pause
    D/GeckoAwesomeBar(31191): creating awesomebar
    D/GeckoAwesomeBarTabs(31191): Creating AwesomeBarTabs
    D/GeckoAwesomeBarTabs(31191): Creating All Pages tab
    D/GeckoAwesomeBarTabs(31191): Creating Bookmarks tab
    D/GeckoAwesomeBarTabs(31191): Creating History tab
    I/ActivityManager( 3097): Displayed activity org.mozilla.fennec_mozdev/org.mozilla.gecko.AwesomeBar: 139 ms (total 139 ms)
    E/AxT9IME ( 6577): WordSymbInit: 1
    I/GeckoApp(31191): stop
    W/GeckoGlobalHistory(31191): Rebuilding visited link set...
    I/GeckoAwesomeBarTabs(31191): Got cursor in 436ms
    W/PowerManagerService( 3097): Timer 0x7->0x3|0x0
    I/PowerManagerService( 3097): Ulight 7->3|0
    V/WindowManager( 3097): Dsptch > Window{483d10a0 org.mozilla.fennec_mozdev/org.mozilla.gecko.AwesomeBar paused=false}
    I/PowerManagerService( 3097): Ulight 3->7|0
    V/WindowManager( 3097): Dsptch > Window{483d10a0 org.mozilla.fennec_mozdev/org.mozilla.gecko.AwesomeBar paused=false}
    E/AxT9IME ( 6577): WordSymbInit: 1
    E/AxT9IME ( 6577): WordSymbInit: 1
    I/dalvikvm(31191): Could not find method java.util.LinkedList.push, referenced from method org.mozilla.gecko.AwesomeBarTabs$BookmarksListAdapter.<init>
    W/dalvikvm(31191): VFY: unable to resolve virtual method 4068: Ljava/util/LinkedList;.push (Ljava/lang/Object;)V
    D/dalvikvm(31191): VFY: replacing opcode 0x6e at 0x0031
    D/dalvikvm(31191): VFY: dead code 0x0034-0034 in Lorg/mozilla/gecko/AwesomeBarTabs$BookmarksListAdapter;.<init> (Lorg/mozilla/gecko/AwesomeBarTabs;Landroid/content/Context;ILandroid/database/Cursor;[Ljava/lang/String;[I)V
    I/dalvikvm(31191): Could not find method java.util.LinkedList.push, referenced from method org.mozilla.gecko.AwesomeBarTabs$BookmarksListAdapter.moveToChildFolder
    W/dalvikvm(31191): VFY: unable to resolve virtual method 4068: Ljava/util/LinkedList;.push (Ljava/lang/Object;)V
    D/dalvikvm(31191): VFY: replacing opcode 0x6e at 0x000b
    D/dalvikvm(31191): VFY: dead code 0x000e-0011 in Lorg/mozilla/gecko/AwesomeBarTabs$BookmarksListAdapter;.moveToChildFolder (ILjava/lang/String;)V
    I/dalvikvm(31191): Could not find method java.util.LinkedList.pop, referenced from method org.mozilla.gecko.AwesomeBarTabs$BookmarksListAdapter.moveToParentFolder
    W/dalvikvm(31191): VFY: unable to resolve virtual method 4067: Ljava/util/LinkedList;.pop ()Ljava/lang/Object;
    D/dalvikvm(31191): VFY: replacing opcode 0x6e at 0x000d
    D/dalvikvm(31191): VFY: dead code 0x0010-0013 in Lorg/mozilla/gecko/AwesomeBarTabs$BookmarksListAdapter;.moveToParentFolder ()Z
    D/AndroidRuntime(31191): Shutting down VM
    W/dalvikvm(31191): threadid=1: thread exiting with uncaught exception (group=0x4001d7d0)
    E/AndroidRuntime(31191): FATAL EXCEPTION: main
    E/AndroidRuntime(31191): java.lang.NoSuchMethodError: java.util.LinkedList.push
    E/AndroidRuntime(31191):        at org.mozilla.gecko.AwesomeBarTabs$BookmarksListAdapter.<init>(AwesomeBarTabs.java:217)
    E/AndroidRuntime(31191):        at org.mozilla.gecko.AwesomeBarTabs$BookmarksQueryTask.onPostExecute(AwesomeBarTabs.java:336)
    E/AndroidRuntime(31191):        at org.mozilla.gecko.AwesomeBarTabs$BookmarksQueryTask.onPostExecute(AwesomeBarTabs.java:329)
    E/AndroidRuntime(31191):        at android.os.AsyncTask.finish(AsyncTask.java:417)
    E/AndroidRuntime(31191):        at android.os.AsyncTask.access$300(AsyncTask.java:127)
    E/AndroidRuntime(31191):        at android.os.AsyncTask$InternalHandler.handleMessage(AsyncTask.java:429)
    E/AndroidRuntime(31191):        at android.os.Handler.dispatchMessage(Handler.java:99)
    E/AndroidRuntime(31191):        at android.os.Looper.loop(Looper.java:123)
    E/AndroidRuntime(31191):        at org.mozilla.gecko.GeckoApp$35.run(GeckoApp.java:1824)
    E/AndroidRuntime(31191):        at android.os.Handler.handleCallback(Handler.java:587)
    E/AndroidRuntime(31191):        at android.os.Handler.dispatchMessage(Handler.java:92)
    E/AndroidRuntime(31191):        at android.os.Looper.loop(Looper.java:123)
    E/AndroidRuntime(31191):        at android.app.ActivityThread.main(ActivityThread.java:4627)
    E/AndroidRuntime(31191):        at java.lang.reflect.Method.invokeNative(Native Method)
    E/AndroidRuntime(31191):        at java.lang.reflect.Method.invoke(Method.java:521)
    E/AndroidRuntime(31191):        at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:858)
    E/AndroidRuntime(31191):        at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:616)
    E/AndroidRuntime(31191):        at dalvik.system.NativeStart.main(Native Method)
    W/ActivityManager( 3097): Error in app org.mozilla.fennec_mozdev running instrumentation ComponentInfo{org.mozilla.roboexample.test/android.test.InstrumentationTestRunner}:
    W/ActivityManager( 3097):   java.lang.NoSuchMethodError
    W/ActivityManager( 3097):   java.lang.NoSuchMethodError: java.util.LinkedList.push
    I/ActivityManager( 3097): Force stopping package org.mozilla.fennec_mozdev uid=10085
    D/AndroidRuntime(31184): Shutting down VM
    D/jdwp    (31184): adbd disconnected
    I/Process ( 3097): Sending signal. PID: 31191 SIG: 9
    I/ActivityManager( 3097):   Force finishing activity HistoryRecord{482d3948 org.mozilla.fennec_mozdev/.App}
    I/Launcher(21259): onResume(). mIsNewIntent : false
    E/        (21259): onResume() check 0
    E/        (21259): onResume() check 1
    E/        (21259): onResume() check 2, mRestoring : false
    E/        (21259): onResume() check 3
    E/        (21259): onResume() check 4
    E/        (21259): onResume() check 5
    I/UsageStats( 3097): Unexpected resume of com.sec.android.app.twlauncher while already resumed in org.mozilla.fennec_mozdev
    I/Launcher(21259): onResume() ended
    I/Launcher(21259): onWindowFocusChanged(true)
    W/Resources( 3097): Converting to boolean: TypedValue{t=0x3/d=0x692e "res/anim/accelerate_decelerate_interpolator.xml" a=1 r=0x10a0004}
    W/WindowManager( 3097): Rebuild removed 4 windows but added 1
    I/WindowManager( 3097): WIN DEATH: Window{48222848 SurfaceView paused=false}
    I/WindowManager( 3097): WIN DEATH: Window{481ebe08 org.mozilla.fennec_mozdev/org.mozilla.fennec_mozdev.App paused=true}
    I/WindowManager( 3097): WIN DEATH: Window{483d10a0 org.mozilla.fennec_mozdev/org.mozilla.gecko.AwesomeBar paused=false}
(Reporter)

Comment 1

6 years ago
LinkedList.push / pop are api level 9. 

Looks like this was introduced in https://hg.mozilla.org/mozilla-central/rev/230c6a8153c6
(Assignee)

Updated

6 years ago
Assignee: nobody → margaret.leibovic
Blocks: 722020
OS: Mac OS X → Android
Hardware: x86 → ARM
Version: unspecified → Trunk
(Assignee)

Comment 2

6 years ago
Created attachment 600480 [details] [diff] [review]
patch

addFirst/removeFirst are basically exactly the same as push/pop, and they're available since API Level 1!
Attachment #600480 - Flags: review?(lucasr.at.mozilla)

Updated

6 years ago
Attachment #600480 - Flags: review?(lucasr.at.mozilla) → review+
(Assignee)

Comment 3

6 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/0714ec049da2

Updated

6 years ago
Duplicate of this bug: 730834
https://hg.mozilla.org/mozilla-central/rev/0714ec049da2
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 13
Verified fixed on:

Firefox 13.0a1 (2012-02-29)
20120229031108
http://hg.mozilla.org/mozilla-central/rev/30b4f99a137c

--
Device: Samsung Galaxy S2
OS: Android 2.3.4
Status: RESOLVED → VERIFIED
status-firefox13: --- → verified
You need to log in before you can comment on or make changes to this bug.