Closed Bug 730478 Opened 10 years ago Closed 10 years ago

element.value returns an empty string after text is input

Categories

(Firefox for Android Graveyard :: Keyboards and IME, defect, P1)

ARM
Android
defect

Tracking

(blocking-fennec1.0 beta+)

RESOLVED DUPLICATE of bug 735469
Tracking Status
blocking-fennec1.0 --- beta+

People

(Reporter: Margaret, Assigned: cpeterson)

Details

This is breaking form autocomplete, since we can't filter the suggestions. This is the line that's failing:

http://mxr.mozilla.org/mozilla-central/source/mobile/android/chrome/content/browser.js#2831

Chris, I'm cc'ing you, since alexp worked on some of these input-related issues. I'm not sure who else would be able to help with this problem.
Hm, actually, I found this works on some forms. However, it is still a problem on:
http://people.mozilla.org/~mwargers/tests/autocomplete_forms/textinput_form.html
blocking-fennec1.0: --- → ?
Having form autocomplete work seems pretty important, since typing on the VKB is cumbersome. :)
This bug is may be related to bug 630576 (Fennec should send key events to content).
chris, is this a bug you can pick up?
blocking-fennec1.0: ? → +
OK. I think this bug is related to bug 630576, which may be an invasive core change. I will investigate.
Assignee: nobody → cpeterson
Triage, this bug needs a priority.
blocking-fennec1.0: + → ?
Beta blocking because form sync is also a beta blocker.
blocking-fennec1.0: ? → beta+
Priority: -- → P1
(In reply to Margaret Leibovic [:margaret] from comment #0)
> This is breaking form autocomplete, since we can't filter the suggestions.
> This is the line that's failing:
> 
> http://mxr.mozilla.org/mozilla-central/source/mobile/android/chrome/content/
> browser.js#2831
> 
> Chris, I'm cc'ing you, since alexp worked on some of these input-related
> issues. I'm not sure who else would be able to help with this problem.

is this an uncommitted composition?
Component: General → IME
Status: NEW → ASSIGNED
> http://people.mozilla.org/~mwargers/tests/autocomplete_forms/textinput_form.html

margaret, what is the expected autocomplete behavior and what are you actually seeing? Which device are you testing?

On my Galaxy S II, autocomplete seems to work correctly, though I get an unfiltered autocomplete box with all possible suggestions *before* I type anything. I don't expect the suggestion list until after I start typing.

On my Galaxy Nexus, the autocomplete menu does not filter the suggestion list until I enter a space.
(In reply to Chris Peterson (:cpeterson) from comment #9)

> On my Galaxy S II, autocomplete seems to work correctly, though I get an
> unfiltered autocomplete box with all possible suggestions *before* I type
> anything. I don't expect the suggestion list until after I start typing.

The unfiltered list is by design. We want "less typing", so we show the list right away.
I am duping this bug with Galaxy Nexus-specific bug 735469. In IRC, margaret confirmed that these are the same problem.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 735469
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.