The default bug view has changed. See this FAQ.

Inconsistent layout with rtl, replacing text node

RESOLVED FIXED in mozilla14

Status

()

Core
Layout
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Jesse Ruderman, Assigned: smontagu)

Tracking

({testcase})

Trunk
mozilla14
testcase
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 600649 [details]
testcase (clicking should have no visible effect)

At first, there are 4 red bars at the top right. After clicking, there are only 3.
(Reporter)

Comment 1

5 years ago
I think this is different from bug 726460, but I'm not sure.
(Assignee)

Comment 2

5 years ago
Created attachment 607805 [details] [diff] [review]
Patch
Assignee: nobody → smontagu
Attachment #607805 - Flags: review?(roc)
(Assignee)

Comment 3

5 years ago
Created attachment 607807 [details] [diff] [review]
The testcase as reftest
Attachment #607807 - Flags: review?(roc)
Attachment #607805 - Flags: review?(roc) → review+
Attachment #607807 - Flags: review?(roc) → review+
(Assignee)

Comment 4

5 years ago
(In reply to Jesse Ruderman from comment #1)
> I think this is different from bug 726460, but I'm not sure.

They're different sides of the same coin. This one is caused by the non-fluid continuation between two frames remaining non-fluid after their content has been deleted; bug 726460 is caused by the the fluid continuation between two frames remaining fluid after the content has been replaced by new content.
(Assignee)

Comment 5

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/a30e6278c122
https://hg.mozilla.org/integration/mozilla-inbound/rev/9f0ebe3d07ff
Flags: in-testsuite+
OS: Mac OS X → All
Hardware: x86_64 → All
Target Milestone: --- → mozilla14
https://hg.mozilla.org/mozilla-central/rev/9f0ebe3d07ff
https://hg.mozilla.org/mozilla-central/rev/a30e6278c122
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Updated

5 years ago
Keywords: testcase
You need to log in before you can comment on or make changes to this bug.