Closed Bug 730768 Opened 9 years ago Closed 5 years ago

embed tag pointing to text/html content doesn't work

Categories

(Core :: DOM: Core & HTML, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1237963

People

(Reporter: alice0775, Unassigned)

References

()

Details

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/ce20e9b47e9c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120225 Firefox/13.0a1 ID:20120225031723

embed tag would not load.
Google Chrome 17.0.963.56m, Opera 11.61 load page successfully. 
Firefox and IE9 fail to load.


Reproducible: Always

Steps to Reproduce:
1. Start Firefox with new profile
2. Open http://www.cannondale.co.jp/bikes/11/supersix.html

Actual Results:
  embed tag would not load

Expected Results:
  Google Chrome 17.0.963.56m, Opera 11.61 load successfully.
Boris: Do you know if there is something in the spec about html content in an embed tag ?
The spec allows pretty wide latitude in handling of <embed>.  It just says it needs to be handled by a "plugin", where "plugin" is defined per http://www.whatwg.org/specs/web-apps/current-work/multipage/infrastructure.html#plugin

That's not actually compatible with pointing an <embed> at an SVG file, though.  I'll post a spec issue.
Component: General → DOM
Product: Firefox → Core
QA Contact: general → general
Summary: embed tag would not load → embed tag pointing to text/html content doesn't work
We got a Web Compatibility issue about this
https://webcompat.com/issues/1138

Boris, was the bug filled on the spec? And if yes, which one? thx :)
Flags: needinfo?(bzbarsky)
> Boris, was the bug filled on the spec?

Pretty sure I filed something, yes....

> And if yes, which one? 

WHATWG "html" spec (the main one Hixie edits), assuming I filed something.
Flags: needinfo?(bzbarsky)
hehe I was asking the bug number not the spec ^_^
Let's see

This one maybe where Hixie says:
https://www.w3.org/Bugs/Public/show_bug.cgi?id=16136

> I've tried to define this better.
> 
> Note that WebKit is way more happy-go-lucky than Gecko with <embed> 
> (e.g. it allows src="" to point to HTML docs or images and happily 
> renders them). I haven't specified this. I don't see much point in 
> opening <embed> to be just a poor man's <object>; that would just 
> lead to more surface for bugs, without adding anything.

With this change to the spec. https://html5.org/r/7914

Going to https://html.spec.whatwg.org/multipage/embedded-content.html#the-embed-element

It seems the fix solved the issue for SVG images, but not that much for HTML documents. Grmph. :)
> https://www.w3.org/Bugs/Public/show_bug.cgi?id=16136

That's my bug report, yes.

> It seems the fix solved the issue for SVG images, but not that much for HTML documents.

Does anyone other than WebKit support non-SVG <embed> with a browsing context?  Because allowing HTML <embed> is not technically particularly difficult, if we're the only holdouts on it...  and then we just ask hixie to change the spec.

Does text/plain embed need to work too, and various other MIME types browsers support as documents?  image/png?
Bug 1237963 fixed this. We should propose a spec update.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1237963
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.