Closed Bug 730798 Opened 11 years ago Closed 11 years ago

Incorrect order of items in live bookmarks in native menubar

Categories

(Firefox :: Bookmarks & History, defect)

All
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 731563

People

(Reporter: cers, Assigned: mak)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

The order of "Live Bookmark Loading..." and "Open <site>" should be reversed, such that Open is always on top, and the loaded items populate the same section as the load indicator.

Steps to reproduce:
1) subscribe to a feed using live bookmarks (in this example, http://www.squarefree.com/burningedge/)
2) click Bookmarks->Bookmarks Toolbar
3) hover over the added feed

Result:
While loading:
 Live Bookmark Loading... (grayed out)
 -------------------------------------
 Open "The Burning Edge"

After loading:
 -------------------------------------
 Open "The Burning Edge"
 2012-02-26 Trunk builds
 (etc)

Expected result:
While loading:
 Open "The Burning Edge"
 -------------------------------------
 Live Bookmark Loading... (grayed out)

After loading:
 Open "The Burning Edge"
 -------------------------------------
 2012-02-26 Trunk builds
 (etc)
my assumption is the usual bug with bindings in native menubar.
we should probably make _startMarker and _endMarker popup expando rather than relying on the binding.
Assignee: nobody → mak77
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Blocks: livemarksIO
Keywords: regression
The missing "Open all in tabs" / nonworking middle click, should be a part of this bug or a new one?
(In reply to Pablo Greco from comment #2)
> The missing "Open all in tabs" / nonworking middle click, should be a part
> of this bug or a new one?

I actually remove that on purpose, cause was adding too much complexity to the patch and its use-cases are limited. Btw, should be a new bug.
I'd actually consider solving this binding issue once and for all. It should be doable by using "visibility" rather than "display" for hiding the menubar.

This could hurt performance, in theory.
her, I actually found we already fixed this in the past, so I have to check what's up since that code should work still!
http://mxr.mozilla.org/mozilla-central/source/browser/components/places/content/browserPlacesViews.js#322
fixing the ordering is trivial, though the whole native menubar binding is quite broken, it just doesn't update correctly :(
Attached patch patch v1.0 (obsolete) — Splinter Review
this fixes ordering, unfortunately, at least on Lion, the binding is completely broken so the livemark never populates and sticks to "Live bookmark loading"
Attachment #601982 - Flags: review?(mano)
note in bug 731563 I basically rewrote the markers to make them a bit less error-prone.
Blocks: 731563
Comment on attachment 601982 [details] [diff] [review]
patch v1.0

hm, at this point I prefer taking directly bug 731563, it just works better (once I figure out why sometimes Lion enforces scrollbox on the popups)
Attachment #601982 - Flags: review?(mano)
No longer blocks: 731563
Depends on: 731563
Attachment #601982 - Attachment is obsolete: true
in the end, I'm just duping this, the issue is basically the same.
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
No longer depends on: 731563
You need to log in before you can comment on or make changes to this bug.