Use a smarter hash function everywhere

RESOLVED DUPLICATE of bug 729940

Status

()

Core
General
RESOLVED DUPLICATE of bug 729940
6 years ago
6 years ago

People

(Reporter: Justin Lebar (not reading bugmail), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
In bug 729952, we identified that our current string hash function is quite poor.

That bug contains an alternative hash function which performs much better.  This bug is about making sure that all relevant code uses this improved hash function, and centralizing the code which computes hashes, so it's easier to change our hash function in the future, if need be.
(Reporter)

Comment 1

6 years ago
Part of this bug will involve removing the hash function calls from nsCRT.
(Reporter)

Comment 2

6 years ago
Didn't notice that bz already had a bug on this.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 729940
You need to log in before you can comment on or make changes to this bug.