new cache problems with bugzilla

VERIFIED FIXED in mozilla0.9

Status

()

Core
Networking: HTTP
VERIFIED FIXED
17 years ago
7 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: gordon)

Tracking

Trunk
mozilla0.9
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [cache])

view a bugzilla report, add a comment, submit, close the window.

open the report again, you get the version you loaded before, prior to your comment.

add a new comment, collision with your last comment.

zoinks!

Comment 1

17 years ago
-->gordon
Assignee: neeti → gordon

Comment 2

17 years ago
sounds more like an HTTP bug to me... investigating.
Assignee: gordon → darin
Component: Networking: Cache → Networking: HTTP

Comment 3

17 years ago
there is a problem with the cache validation setting of "once per session"
we compare the session start time against the last modified time of the cache
entry, and it looks like the cache entry is always modified!  not sure if this
is http's fault or the cache's.  investigating...
Status: NEW → ASSIGNED
QA Contact: gordon → tever
Target Milestone: --- → mozilla0.9

Updated

17 years ago
Keywords: nsbeta1

Comment 4

17 years ago
*** Bug 73417 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Blocks: 73293

Updated

17 years ago
No longer blocks: 73293

Comment 5

17 years ago
ok.. this is not an HTTP bug.  the disk cache calls SetDataSize() and SetData()
on disk cache entries while reading the data from disk (readDiskCacheEntry).
this results in the lastModified time stamp being updated.  this is not
correct, since lastModified should only be updated to reflect the last time
the cache client (in this case HTTP) modified the cached data.

gordon: cache entry descriptor needs to tell the cache entry when to update
its last modified time stamp.  it doesn't make sense for the cache entry to
try to do this automagically.
Assignee: darin → gordon
Status: ASSIGNED → NEW

Comment 6

17 years ago
this is dogfood for someone who spends his day in Bugzilla. 
Keywords: nsdogfood
(Assignee)

Comment 7

17 years ago
Darin, this has already been fixed on the DISKCACHE1_BRANCH, which we hope to 
land in the next day or so.
(Assignee)

Updated

17 years ago
Whiteboard: [cache]

Comment 8

17 years ago
my fix for bug 73490 should make this bug appear to be fixed.
Whiteboard: [cache]

Updated

17 years ago
Whiteboard: [cache]

Comment 9

17 years ago
gordon: make sure this problem is fixed WITHOUT darin's fix of bug 73490 since 
his fix will mask this to be less frequently visible and make you believe that 
this is fixed.

Comment 10

17 years ago
this bug can be verified using about:cache.  upon revisiting a cached page,
the last-modified time stamp should not change, unless the page was refetched
or validated with the server.  changing your cache preferences to validate
never should help make verification easier.
(Assignee)

Comment 11

17 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 12

17 years ago
*** Bug 73921 has been marked as a duplicate of this bug. ***

Comment 13

17 years ago
*** Bug 73924 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
Verified Linux 2001062021
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.