Last Comment Bug 731134 - Navigator mozapps implementation for mozilla-central
: Navigator mozapps implementation for mozilla-central
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Apps (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: 746465
  Show dependency treegraph
 
Reported: 2012-02-28 00:10 PST by dclarke@mozilla.com [:onecyrenus]
Modified: 2012-07-28 09:25 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
repo_api failure output (31.88 KB, application/zip)
2012-02-28 00:10 PST, dclarke@mozilla.com [:onecyrenus]
no flags Details

Description dclarke@mozilla.com [:onecyrenus] 2012-02-28 00:10:09 PST
Created attachment 601199 [details]
repo_api failure output

The navigator mozApps implementation for mozilla-central is not currently the same as the extension, soup. 

Attached is my test run data from the mochitests i ported. 

A few things I noticed
navigator.mozApps.mgmt is undefined
Error: navigator.mozApps.getInstalled is not a function

navigator.mozApps.setMockResponse(,,); <-- this function is used under test

I am fixing up some of the other issues with the tests, but this seems reasonable to start submitting data now.
Comment 1 [:fabrice] Fabrice Desré 2012-02-28 07:22:11 PST
There is nothing surprising here, since the implementation of the new API has not landed yet on m-c
Comment 2 Ian Bicking (:ianb) 2012-02-28 13:18:01 PST
What I do think we should have for testing support is two hidden preferences: one that disables user confirmation of application installation, and another to set what sites have mozApps.mgmt privileges.  These will make it much easier to automate testing (and would serve the same purpose as setMockResponse).
Comment 3 Ian Bicking (:ianb) 2012-06-08 14:24:19 PDT
The implementation has landed.

Note You need to log in before you can comment on or make changes to this bug.