Tearing 2 tabs then merging one of them leaks chrome://browser/content/browser.xul

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: Loic, Assigned: mccr8)

Tracking

(Blocks: 1 bug)

13 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MemShrink:P3])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120228 Firefox/13.0a1
Build ID: 20120228031102

Steps to reproduce:

STR:

0) Start a new profile with Nightly
1) Install the add-on about:ccdump to hunt the leak:
https://addons.mozilla.org/en-US/firefox/addon/cycle-collector-analyzer/
2) Open a 1st tab and go to about:ccdump
3) Open a 2nd tab (and go to http://www.nytimes.com/ e.g.)
4) Open a 3rd tab (and go to http://www.latimes.com/ e.g.)
5) Tear the 2nd tab
6) Tear the 3rd tab
NB: at this step, you have 3 windows (about:ccdump, nytimes.com and latimes.com)
7) Grab the tab of the 2nd window (nytimes.com) and drop it on the left/right of the tab of the 3rd window (latimes.com)
8) Close the resulting window (confirm close if necessary)
9) Go back to tab about:ccdump, Run CC Analysis and search for nsDocument

Results:
nsDocument normal (XUL) chrome://browser/content/browser.xul leaks.
Root objects:
root nsNodeInfoManager
root XPCVariant

At step #7, you can grab the tab of the 2nd window and merge it with the 1st window and closing the 3rd window, same result.
Idem with the 3rd window.
(Reporter)

Updated

6 years ago
Blocks: 728407
Component: Untriaged → General
Whiteboard: [MemShrink]

Comment 1

6 years ago
browser.xul was in the cc log for some time, but then disappeared.
Did you run CC several times?
(Reporter)

Comment 2

6 years ago
Yes, I ran CC several times. In addition, 'Run CC Analysis' in about:ccdump runs Firefox CC three times to clean up garbage.
Assignee: nobody → continuation

Comment 3

6 years ago
What is "tearing" a tab?
(Reporter)

Comment 4

6 years ago
Tab tearing allows you to pull any tab out of your Firefox window into a completely new window or pull any tab into another window.
Whiteboard: [MemShrink] → [MemShrink:P3]
(Reporter)

Comment 5

6 years ago
Did someone try to reproduce it?
(Assignee)

Comment 6

6 years ago
Sorry, I've forgotten to look at this. We marked it P3 because this seems like an uncommon operation.

Updated

6 years ago
QA Contact: untriaged → general
(Assignee)

Comment 7

6 years ago
This doesn't reproduce for me any more.
Loic, can you still reproduce?
(Reporter)

Comment 9

6 years ago
(In reply to Nicholas Nethercote [:njn] from comment #8)
> Loic, can you still reproduce?

No. I guess you can close it.
(Assignee)

Comment 10

6 years ago
Thanks for looking.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.