If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

The Next button is not present on the landscape vkb for login pages when focusing text fields

RESOLVED DUPLICATE of bug 720475

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 720475
6 years ago
a year ago

People

(Reporter: Paul Feher, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [vkb])

(Reporter)

Description

6 years ago
Fennec/13.0a1 2012-02-29
Device: Motorola Droid Pro ( Android 2.3.3)

Steps to reproduce:
1. Open Fennec.
2. Go to a page with a login and password field like gmail.com.
3. Put the phone in landscape mode and tap in the login field to bring up the vkb.
4. Enter some text and observe the vkb.

Expected results:
There is a next button to navigate between the different text fields regardless of their type.

Actual results:
The Next button does not exist. Only a "Go" button exists, which tries to login in using just the username and no password when pressed.

Notes:
-- The issue is not reproducible on the Android Browser. On the Android browser a different keyboard is opened with a Next and Space button in place of the Space button is opened when there are more then one text field present.

Updated

6 years ago
Whiteboard: [vkb]
This bug is pretty bad.

On ICS, the stock Browser and Chrome Beta bring up half-height VKBs in landscape mode. Their VKBs do not obscure the HTML form.

However, I see "Go" buttons, not "Next" buttons. And their "Go" buttons have the same problem as Fennec's, BUT is not as serious a problem because the HTML form is not obscured (allowing the user to manually tap focus to the gmail password field).
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 720475
You need to log in before you can comment on or make changes to this bug.