Closed Bug 731670 Opened 9 years ago Closed 9 years ago

Figure out changing MAC address for panda boards

Categories

(Testing :: General, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: armenzg, Assigned: ted)

References

Details

It seems that we have a kernel issue that does not allow us to have a fixed MAC address which becomes troublesome.

This is important to figure out if we want an scalable reliable solution.
Assignee: ctalbert → ted.mielczarek
So after quite a bit of fumbling around, we found this blog post:
http://blog.bisect.de/2012/01/pandaboard-get-persistent-mac-address.html

It turns out that Linaro has this patch applied to their kernel tree, so I took a stock Linaro build (downloaded the tarballs from http://releases.linaro.org/12.05/android/leb-panda/ ) and edited the u-boot script as directed there. I now have an SD card image that boots with a reliable MAC address.

I'm cloning the Linaro repos to try to build my own image and see if I can repeat that.
This seems to be done.
RESOLVED FIXED? or waiting on someone else to verify?
I'd like to get at least one other person to verify that it works for them before closing this out.
Jake successfully used this image, so I'm going to call this fixed.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Just for posterity, it turned out that the linaro build had a kernel patch already applied to generate a unique mac from the die id.  I removed the smsc95xx.macaddr= from the boot.scr and confirmed both uboot and android were generating mac address identical but unique to the board and consistent through reboots.  I have tested this on several boards.

http://android.git.linaro.org/gitweb?p=kernel/panda.git;a=commit;h=ff537fc08cb2b6b64ee19da829229e8d179ef97b
Huh! I thought I tested and was seeing a randomized mac before I did this hacking. Perhaps I was testing with a different build. (maybe Clint's?) In any event, moving to the Linaro build instead of AOSP was helpful.

Thanks for updating the wiki!
You need to log in before you can comment on or make changes to this bug.