Closed
Bug 731697
Opened 13 years ago
Closed 13 years ago
Build directories and builder names need to be differentiated across products
Categories
(Release Engineering :: General, defect)
Tracking
(Not tracked)
RESOLVED
FIXED
People
(Reporter: jhopkins, Assigned: jhopkins)
References
Details
Attachments
(1 file)
78.67 KB,
patch
|
Details | Diff | Splinter Review |
We need to differentiate builder names like "Linux try build" and builddirs like 'try-linux' across the Thunderbird and Firefox products so they don't collide.
Basically, we want 'try-linux' to remain for Firefox but 'tb-try-linux' for Thunderbird. Same idea with builder names - they shouldn't change for Firefox.
Assignee | ||
Comment 1•13 years ago
|
||
This patch passes 'checkconfig' but no testing beyond that has been done yet.
Attachment #602028 -
Flags: review?(bhearsum)
Assignee | ||
Updated•13 years ago
|
Comment 2•13 years ago
|
||
Comment on attachment 602028 [details] [diff] [review]
proposed patch
Review of attachment 602028 [details] [diff] [review]:
-----------------------------------------------------------------
r=me with the below comments addressed.
::: common.py
@@ +32,5 @@
> return uuid.uuid4().hex
>
> +def productPrefix(product):
> + if product == 'thunderbird':
> + return 'tb'
I think you probably want tb- here for readability's sake.
::: misc.py
@@ +813,5 @@
> nomergeBuilders.extend(periodicPgoBuilders) # these should never, ever merge
> extra_args['treeStableTimer'] = None
>
> branchObjects['schedulers'].append(scheduler_class(
> + name=productPrefix(pf['product_name']) + name,
I think it's unnecessary to use productPrefix here. Scheduler names aren't a risky thing to change. You can just prepend the product name to all of them to keep things simpler.
::: process/release.py
@@ -332,1 @@
>
Can we save the patch to this file for when Tb release integration happens? I'm just a bit concerned about it landing untested.
Comment 3•13 years ago
|
||
(In reply to Ben Hearsum [:bhearsum] from comment #2)
> Comment on attachment 602028 [details] [diff] [review]
> proposed patch
>
> Review of attachment 602028 [details] [diff] [review]:
> -----------------------------------------------------------------
>
> r=me with the below comments addressed.
>
> ::: common.py
> @@ +32,5 @@
> > return uuid.uuid4().hex
> >
> > +def productPrefix(product):
> > + if product == 'thunderbird':
> > + return 'tb'
>
> I think you probably want tb- here for readability's sake.
>
> ::: misc.py
> @@ +813,5 @@
> > nomergeBuilders.extend(periodicPgoBuilders) # these should never, ever merge
> > extra_args['treeStableTimer'] = None
> >
> > branchObjects['schedulers'].append(scheduler_class(
> > + name=productPrefix(pf['product_name']) + name,
>
> I think it's unnecessary to use productPrefix here. Scheduler names aren't a
> risky thing to change. You can just prepend the product name to all of them
> to keep things simpler.
We talked about this on the phone and decided to leave it as is. So, r=me with the tb prefix fixed, and removing the release.py part of the patch.
Comment 4•13 years ago
|
||
Comment on attachment 602028 [details] [diff] [review]
proposed patch
Removing review per comment #3.
Attachment #602028 -
Flags: review?(bhearsum)
Assignee | ||
Comment 5•13 years ago
|
||
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Updated•12 years ago
|
Product: mozilla.org → Release Engineering
You need to log in
before you can comment on or make changes to this bug.
Description
•