Closed Bug 731846 Opened 8 years ago Closed 8 years ago

crash ntdll by nsFilePicker::ShowFolderPicker

Categories

(Core :: Widget: Win32, defect, critical)

13 Branch
All
Windows 8
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Tracking Status
firefox13 - ---

People

(Reporter: Logan, Assigned: khuey)

References

Details

(4 keywords)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-91447e57-fa53-4726-949b-d3bac2120229 .
============================================================= 
Clicking the "Browse..." button in Tools-->Options-->General in the Download section causes this crash in the Windows 8 Consumer Preview.
Component: Preferences → Widget: Win32
Product: Firefox → Core
QA Contact: preferences → win32
Summary: crash ntdll → crash ntdll by nsFilePicker::ShowFolderPicker
Regression window:
Not crash:
http://hg.mozilla.org/mozilla-central/rev/c827c52c4603
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:13.0) Gecko/20120222 Firefox/13.0a1 ID:20120222172017
Crashes:
http://hg.mozilla.org/mozilla-central/rev/5e756e59a794
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:13.0) Gecko/20120223 Firefox/13.0a1 ID:20120223031236
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c827c52c4603&tochange=5e756e59a794

Triggered by;
b7582d84aa15	Kyle Huey — Bug 728429: Require ASLR for binary components on Windows. r=bsmedberg,ehsa
Blocks: 728429
I added crash signatures with similar regression ranges, stacks and comments.
It's #1 top crasher over the last day in the trunk.
Crash Signature: [@ ntdll.dll@0x54f10] → [@ ntdll.dll@0x54f10] [@ ntdll.dll@0x5bb4] [@ ntdll.dll@0x17155]
Hardware: x86 → All
Version: Trunk → 13 Branch
Duplicate of this bug: 732038
"I told you so" :-P

Does this correlate with particular version(s) of Windows or anything else interesting?
Assignee: nobody → khuey
Hrm, is this windows 8 preview only? The three signatures here appears to be

Windows NT 6.2.8250 	amd64
Windows NT 6.2.8250 	x86
Windows NT 6.2.8250 	x86
Depends on: 730051
Duplicate of this bug: 732138
Duplicate of this bug: 732157
Not crash on Last m-c hourly anymore.
http://hg.mozilla.org/mozilla-central/rev/3a7b9e61c263
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:13.0) Gecko/20120301 Firefox/13.0a1 ID:20120301110740
Verified that the crash no longer occurs in the latest hourly (http://hg.mozilla.org/mozilla-central/rev/3a7b9e61c263) on Windows 8 CP build 8250 x64
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.