Closed Bug 731917 Opened 8 years ago Closed 8 years ago

plugin corrupts the stack with ipc disabled

Categories

(Core :: Plug-ins, defect)

10 Branch
All
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla13

People

(Reporter: ginnchen+exoracle, Assigned: ginnchen+exoracle)

References

Details

Attachments

(1 file, 1 obsolete file)

See also Bug 535073, Bug 348247

With Bug 675553, we introduced this bug.

Since Flashplayer is already using "int" for NPPVpluginNeedsXEmbed, we need to revert the change and set Bug 348247 as won't fix.

This bug caused a misbehavior on SPARC because it is big-endian.
Attached patch patch (obsolete) — Splinter Review
Assignee: nobody → ginn.chen
Status: NEW → ASSIGNED
Attachment #602212 - Flags: review?(karlt)
Comment on attachment 602212 [details] [diff] [review]
patch

>+      // treats NPPVpluginNeedsXEmbed as bool (int), and

Replace "bool" with "PRBool", please.  That is probably also a regression from bug 675553.

>+      PRUint32 needsXEmbed = 0;

And please replace PRUint32 with "int" to match PRBool.

And as you suggest these should be the same in CallSetWindow and in NPNVxDisplay.
Attachment #602212 - Flags: review?(karlt) → review+
Blocks: 348247
Attached patch patchSplinter Review
also fix the origin
Attachment #602212 - Attachment is obsolete: true
Attachment #602242 - Flags: review?(karlt)
Comment on attachment 602242 [details] [diff] [review]
patch

Thanks!
Attachment #602242 - Flags: review?(karlt) → review+
https://hg.mozilla.org/mozilla-central/rev/02dcec807422
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla13
You need to log in before you can comment on or make changes to this bug.