Closed Bug 731919 (brikbot) Opened 10 years ago Closed 10 years ago

Downloader does not save file

Categories

(Firefox :: General, defect)

x86
Windows 8
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 13

People

(Reporter: portsidepaul, Unassigned)

References

Details

File download immediately fails on starting.  On restarting the download, the file will download, but disappears from the destination folder as soon as the download completes.  To duplicate, simply attempt to download a file.  It should immediately fail.  Then attempt to "Retry" that failed download.  This time it will download, but the file will vanish from the download location in Windows Explorer once the download has completed.

Possibly related is that FF seems to crash on any "Save As" type of operation with Windows 8 Consumer Preview.  To reproduce, go to the file menu and select "Save As".  FF should promptly crash and request to send a crash report (I have submitted several at this point, just trying to ensure the above really is a bug).

This bug that appears to be specific to Windows 8 Consumer Preview.  It did not appear with the developer preview nor does it appear to occur with Windows 7/Server 2008.  I have experience it on both Win8 beta installs I have running.
Regression window:
Not crash:
http://hg.mozilla.org/mozilla-central/rev/c827c52c4603
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:13.0) Gecko/20120222 Firefox/13.0a1 ID:20120222172017
Crashes:
http://hg.mozilla.org/mozilla-central/rev/5e756e59a794
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:13.0) Gecko/20120223 Firefox/13.0a1 ID:20120223031236
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c827c52c4603&tochange=5e756e59a794

Triggered by;
b7582d84aa15	Kyle Huey — Bug 728429: Require ASLR for binary components on Windows. r=bsmedberg,ehsa

Blocks: 728429
Blocks: 728429
Duplicate of this bug: 732066
I cannot reproduce on Last m-c hourly anymore.
http://hg.mozilla.org/mozilla-central/rev/3a7b9e61c263
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:13.0) Gecko/20120301 Firefox/13.0a1 ID:20120301110740
Depends on: 730051
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 13
You need to log in before you can comment on or make changes to this bug.