Last Comment Bug 731934 - QuickDrag add-on creates successive zombie compartments
: QuickDrag add-on creates successive zombie compartments
Status: RESOLVED WONTFIX
[MemShrink:P3]
:
Product: Firefox
Classification: Client Software
Component: Untriaged (show other bugs)
: 13 Branch
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: LeakyAddons ZombieCompartments
  Show dependency treegraph
 
Reported: 2012-02-29 23:46 PST by her34her34
Modified: 2012-03-21 12:41 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description her34her34 2012-02-29 23:46:32 PST
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20120228 Firefox/13.0a1
Build ID: 20120228031102

Steps to reproduce:

https://addons.mozilla.org/en-US/firefox/addon/quickdrag/

Open any website and drag link to open in new tab. Close original tab and new tab from link.


Actual results:

Go to about:compartments and Zombie Compartment exists even though all tabs are closed 


Expected results:

about:compartments should be empty
Comment 1 Nicholas Nethercote [:njn] 2012-03-01 00:47:14 PST
Jorge, do we have a contact point for Stevie Smith, the developer of QuickDrag?
Comment 2 Jorge Villalobos [:jorgev] 2012-03-07 15:23:36 PST
I can confirm the leak occurs and a reference is kept for the document where the drag originated from. Doing a second drag with different documents just replace the zombie compartment, so it isn't a cumulative problem.

The developer has been informed through AMO.
Comment 3 Jorge Villalobos [:jorgev] 2012-03-21 12:41:05 PDT
The add-on has been downgraded to preliminary review. Since this is a single compartment leak, no further action is required unless the developer wants the add-on to be fully public again.

Note You need to log in before you can comment on or make changes to this bug.