If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Setting the landscape keyboard option to not be in fullscreen does not have any effect on the URL bar

RESOLVED INVALID

Status

()

Firefox for Android
General
RESOLVED INVALID
6 years ago
a year ago

People

(Reporter: Camelia Urian, Assigned: cpeterson)

Tracking

({uiwanted})

Trunk
ARM
Android
uiwanted
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 -)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Fennec/13.0a1 2012-02-29
Device: Motorola Droid Pro ( Android 2.3.3)
        HTC Desire Z (Android 2.3.3)
        Samsung Nexus S (Android 2.3.6)

Steps to reproduce:
1. Go to about:config.
2. Set widget.ime.android.landscape_fullscreen=0 and widget.ime.android.fullscreen_threshold=300.
3. Go to google.com and set the device in landscape mode.
4. Tap in the text field to bring up the landscape virtual keyboard.
5. Move the focus to the URL bar and open the virtual keyboard there.

Expected results:
In both cases the VKB is not in fullscreen mode.

Actual results:
In the text field the VKBis half screen. In the URL bar the VKB is the fullscreen version.

Notes:
-- The issue is not reproducible on the Firefox Mobile Beta XUL
(Reporter)

Comment 1

6 years ago
Created attachment 601929 [details]
Device screen shots

Comment 2

6 years ago
We're using a completely native text box for the urlbar, so we're likely not reading any gecko prefs in that case, and I'm not sure we want to be.
(Assignee)

Comment 3

6 years ago
I'm not sure if our URL bar should be checking the config prefs, BUT I do think the fullscreen landscape keyboard is a bad (and ugly) experience.
Based on comment #3, sounds like UX input is needed here.
blocking-fennec1.0: --- → ?
Keywords: uiwanted

Updated

6 years ago
Assignee: nobody → cpeterson

Comment 5

6 years ago
based on comment #0, i am pretty sure this bug is invalid.  Chris?
(Assignee)

Comment 6

6 years ago
dougt, ibarlow says the Awesome Screen should show the VKB in landscape mode. We don't want to obscure the top-sites/bookmarks/history lists, so the landscape VKB should be non-fullscreen.
(Assignee)

Comment 7

6 years ago
I'm marking this bug as invalid because I think we are deprecating widget.ime.android.landscape_fullscreen. We plan to default to non-fullscreen landscape keyboard soon, so your preference will become the new default. :)
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
(Assignee)

Updated

6 years ago
Depends on: 733147

Updated

5 years ago
blocking-fennec1.0: ? → -
You need to log in before you can comment on or make changes to this bug.