Closed Bug 731984 Opened 10 years ago Closed 10 years ago

Crash @ ffi_call with Roboform2Go 7.7.3

Categories

(Firefox :: Extension Compatibility, defect)

10 Branch
x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: scoobidiver, Unassigned)

References

Details

(Keywords: crash, reproducible, Whiteboard: [fixed in Roboform2Go 7.7.4])

Crash Data

It's #148 top crasher in 10.0.2 and #67 in 11.0b4.

It's correlated to Roboform 7.7.3:
* 10.0.2:
  ffi_call|EXCEPTION_ACCESS_VIOLATION_EXEC (334 crashes)
    100% (334/334) vs.   1% (566/70876) roboform.dll
        100% (334/334) vs.   1% (402/70876) 7.7.3.0
  ffi_call|EXCEPTION_ACCESS_VIOLATION_READ (31 crashes)
    100% (31/31) vs.   1% (566/70876) roboform.dll
        100% (31/31) vs.   1% (402/70876) 7.7.3.0
* 11.0:
  ffi_call|EXCEPTION_ACCESS_VIOLATION_EXEC (153 crashes)
     99% (152/153) vs.   1% (351/34940) roboform.dll
         99% (152/153) vs.   1% (296/34940) 7.7.3.0
  ffi_call|EXCEPTION_ACCESS_VIOLATION_READ (77 crashes)
    100% (77/77) vs.   1% (351/34940) roboform.dll
        100% (77/77) vs.   1% (296/34940) 7.7.3.0

Signature 	ffi_call More Reports Search
UUID	100bc8a8-2ab3-4bed-b3cf-73e3a2120301
Date Processed	2012-03-01 10:56:04
Uptime	609
Last Crash	10.3 minutes before submission
Install Age	8.9 hours since version was first installed.
Install Time	2012-03-01 02:00:00
Product	Firefox
Version	10.0.2
Build ID	20120215223356
Release Channel	release
OS	Windows NT
OS Version	6.0.6002 Service Pack 2
Build Architecture	x86
Build Architecture Info	GenuineIntel family 6 model 15 stepping 6
Crash Reason	EXCEPTION_ACCESS_VIOLATION_EXEC
Crash Address	0xee61010
User Comments	wie oft noch ? wann wird das problem endlich behoben ? werden die mails überhaupt gelesen ß
App Notes 	
AdapterVendorID: 10de, AdapterDeviceID: 0398, AdapterSubsysID: 00901025, AdapterDriverVersion: 7.15.10.9735
D3D10 Layers? D3D10 Layers-
D3D9 Layers? D3D9 Layers-
WebGL? WebGL-
EMCheckCompatibility	True	
Total Virtual Memory	2147352576
Available Virtual Memory	1754304512
System Memory Use Percentage	68

Frame 	Module 	Signature [Expand] 	Source
0 		@0xee61010 	
1 	mozjs.dll 	ffi_call 	js/src/ctypes/libffi/src/x86/ffi.c:299
2 	mozjs.dll 	js::ctypes::FunctionType::Call 	js/src/ctypes/CTypes.cpp:5121
3 	mozjs.dll 	js::InvokeKernel 	js/src/jsinterp.cpp:622
4 	mozjs.dll 	js::mjit::stubs::SlowCall 	js/src/methodjit/InvokeHelpers.cpp:196
5 	mozjs.dll 	js::mjit::ic::NativeCall 	js/src/methodjit/MonoIC.cpp:1174
6 	mozjs.dll 	js::mjit::EnterMethodJIT 	js/src/methodjit/MethodJIT.cpp:1064
7 	mozjs.dll 	js::mjit::JaegerShot 	js/src/methodjit/MethodJIT.cpp:1142
8 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:3987
9 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:584
10 	mozjs.dll 	js::InvokeKernel 	js/src/jsinterp.cpp:647
11 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:679
12 	mozjs.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:5199
13 	xul.dll 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:1937
14 	xul.dll 	nsGlobalWindow::RunTimeout 	dom/base/nsGlobalWindow.cpp:9307
15 	xul.dll 	nsGlobalWindow::TimerCallback 	dom/base/nsGlobalWindow.cpp:9747
16 	xul.dll 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:425
17 	xul.dll 	nsTimerEvent::Run 	xpcom/threads/nsTimerImpl.cpp:521
18 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:631
19 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:134
20 	xul.dll 	xul.dll@0xbbc98f 	
21 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:201
22 	xul.dll 	_SEH_epilog4 	
23 	xul.dll 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:175
24 	xul.dll 	mozilla::storage::AsyncBindingParams::`scalar deleting destructor' 	
25 		@0x65726965 	

More reports at:
https://crash-stats.mozilla.com/report/list?signature=ffi_call
I've gotten this several times and I've found a 100% way to reproduce it in both Firefox 10 and 11.

1. Download and install the Exif Viewer 1.81 add-on from https://addons.mozilla.org/en-US/firefox/addon/exif-viewer/
2. Restart and go to Tools and open the EXIF Viewer window and choose a local jpg file with embedded GPS data.
3. Click Display EXIF data and scroll down to the "Google Maps" link and click it.
4. When the new windows open, the browser will crash with either a FFI_CALL crash or a specific crash in Roboform.dll itself.

Here's some crash signatures:

bp-e4b5795b-b9c8-4054-89be-a14282120301
bp-4f719fdf-87b3-4e94-aa63-305842120301
bp-bbd41f33-ff53-40e1-975b-b58c92120301
bp-0914110e-7ae0-4182-9e43-63d3a2120301
bp-ce21eb83-8ae6-402e-80c4-506d12120301
Keywords: reproducible
I'll also mention that when I went back to Roboform2Go 7.7.2, the above steps will not cause a crash.
we will take a look at it
Actually I found an easier way to reproduce it.  Simply open a new browser window.  That seems to have a high chance of crashing the browser.  I have Firefox set to "Show My Homepage" in the General startup option and pressing CTRL-N to open a window starts to display the homepage and then Firefox promptly crashes (most of the time).
(In reply to Vadim Maslov from comment #3)
> we will take a look at it

If you want some data to look at, I filed an internal bug report (tid 554128) at the Roboform support site with Roboform crash dumps since sometimes Firefox crashes in mozjs.dll::ffi_call and other times it crashes in roboform.dll itself.

https://crash-stats.mozilla.com/report/list?signature=roboform.dll%400x2a40c5
Duplicate of this bug: 732388
Fixed in these new releases, pls verify:

http://www.roboform.com/dist/RoboForm-Setup-7-7-4.exe
http://www.roboform.com/dist/RoboForm-2Go-Setup-7-7-4.exe

Developers say that it happens in pure RF2Go only, not in regular installed RF.
I'm unable to reproduce the original crash in Firefox 11.0b5 on Windows 7 64-bit with RoboForm 7.7.3, as a consequence I am unable to verify that RoboForm 7.7.4 fixes this issue.
(In reply to Michael Kraft [:morac] from comment #5)
> (In reply to Vadim Maslov from comment #3)
> > we will take a look at it
> 
> If you want some data to look at, I filed an internal bug report (tid
> 554128) at the Roboform support site with Roboform crash dumps since
> sometimes Firefox crashes in mozjs.dll::ffi_call and other times it crashes
> in roboform.dll itself.
> 
> https://crash-stats.mozilla.com/report/list?signature=roboform.dll%400x2a40c5

Michael - would you mind attempting to reproduce with the builds in comment#7? Much appreciated!
(In reply to Alex Keybl [:akeybl] from comment #9)
> Michael - would you mind attempting to reproduce with the builds in
> comment#7? Much appreciated!

I tried for a few minutes to get Firefox to crash when running Roboform2Go 7.7.4 and could not. Under 7.7.3 I would have crashed numerous times by that point. 

So it looks to be fixed in 7.7.4.
(In reply to Michael Kraft [:morac] from comment #10)
> (In reply to Alex Keybl [:akeybl] from comment #9)
> > Michael - would you mind attempting to reproduce with the builds in
> > comment#7? Much appreciated!
> 
> I tried for a few minutes to get Firefox to crash when running Roboform2Go
> 7.7.4 and could not. Under 7.7.3 I would have crashed numerous times by that
> point. 
> 
> So it looks to be fixed in 7.7.4.

Thanks for the confirmation!

Vadim - do you plan to roll 7.7.4 out soon?
Summary: Crash @ ffi_call with Roboform 7.7.3 → Crash @ ffi_call with Roboform2Go 7.7.3
Whiteboard: [fixed in Roboform2Go 7.7.4]
We will release it later today or tomorrow
These crashes are on their way down. I assume the new version has addressed the problem.
Based on comment 10 and latest correlations per module on 10.0.2:
         99% (94/95) vs.   0% (126/73873) 7.7.3.0
          0% (0/95) vs.   0% (13/73873) 7.7.4.0
I close it as work for me.
Assignee: general → nobody
Status: NEW → RESOLVED
Closed: 10 years ago
Component: JavaScript Engine → Extension Compatibility
Product: Core → Firefox
QA Contact: general → extension.compatibility
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.