Closed Bug 732059 Opened 10 years ago Closed 9 years ago

crash in TimerThread::UpdateFilter @ libflashplayer.so@0x53...

Categories

(Core :: XPCOM, defect)

14 Branch
ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 750217
Tracking Status
blocking-fennec1.0 --- -

People

(Reporter: nhirata, Assigned: snorp)

Details

(Keywords: crash, qawanted, topcrash, Whiteboard: [native-crash], str-wanted)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-58878c8a-a827-4df3-a950-0d01b2120229 .
============================================================= 
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	libflashplayer.so 	libflashplayer.so@0x53f496 	
1 	libxul.so 	TimerThread::UpdateFilter 	xpcom/threads/TimerThread.cpp:241
2 	libxul.so 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:428
3 	libxul.so 	nsTimerEvent::Run 	xpcom/threads/nsTimerImpl.cpp:524
4 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:657
5 	libxul.so 	NS_ProcessNextEvent_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:245
6 	libxul.so 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:110
7 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:208
8 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:201
9 	libxul.so 	nsBaseAppShell::Run 	widget/xpwidgets/nsBaseAppShell.cpp:189
10 	libxul.so 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:295
11 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3564
12 	libxul.so 	GeckoStart 	toolkit/xre/nsAndroidStartup.cpp:109
13 	libmozglue.so 	__res_nsend 	other-licenses/android/res_send.c:599
14 	dalvik-heap (deleted) 	dalvik-heap @0x552cce 	
15 	dalvik-heap (deleted) 	dalvik-heap @0x593616 	
16 	libdvm.so 	dvmPlatformInvoke 	
17 	libdvm.so 	dvmCallJNIMethod_general 	
18 	libdvm.so 	dvmResolveNativeMethod 	
19 	libdvm.so 	dvmAsmSisterStart 	
20 	libdvm.so 	dvmMterpStd 	
21 	libdvm.so 	dvmInterpret 	
22 	libdvm.so 	dvmCallMethodV 	
23 	libdvm.so 	dvmCallMethod 	
24 	libdvm.so 	dvmDetachCurrentThread 	
25 	libc.so 	__thread_entry 	
26 	libc.so 	pthread_create 


https://crash-stats.mozilla.com/report/list?range_value=7&range_unit=days&date=2012-03-01&signature=libflashplayer.so%400x53f496&version=FennecAndroid%3A13.0a1

Device: Samsung 'GT-I9100'
OS versions:
0.0.0 Linux 2.6.35.14-Siyah-v2.6.12+ #406 SMP PREEMPT Sun Feb 5 21:11:36 EET 2012 armv7l
Linux 0.0.0 Linux 2.6.35.7-I9100XWLA4-CL900411 #2 SMP PREEMPT Tue Jan 17 15:24:22 CET 2012 armv7l

Device : 
'Android, Model: 'MB860', Product: 'olyatt', Manufacturer: 'motorola'
OS: 0.0.0 Linux 2.6.32.56-MB860-faux123-GB-024 #5 SMP PREEMPT Sat Feb 4 15:43:43 PST 2012 armv7l

More crashes:
https://crash-stats.mozilla.com/query/query?product=FennecAndroid&version=ALL%3AALL&range_value=30&range_unit=days&date=03%2F01%2F2012+17%3A28%3A20&query_search=signature&query_type=contains&query=libflashplayer.so%400x53f496&reason=&build_id=&process_type=any&hang_type=any&do_query=1
Snorp, not sure if this is just a flash thing... it may be something with our code?
Another set with a different address:
https://crash-stats.mozilla.com/report/index/62c21d68-efcd-42c1-a605-28fa42120228

https://crash-stats.mozilla.com/report/list?signature=libflashplayer.so%400x53f496
Crash Signature: [@ libflashplayer.so@0x53f496] → [@ libflashplayer.so@0x53f496] [@ libflashplayer.so@0x53f496]
Still having issues with Socorro picking up the bugs correctly.
Crash Signature: [@ libflashplayer.so@0x53f496] [@ libflashplayer.so@0x53f496] → [@ libflashplayer.so@0x53f496] [@ libflashplayer.so@0x53f496] [@ libflashplayer.so@0x53f496 ]
Crash Signature: [@ libflashplayer.so@0x53f496] [@ libflashplayer.so@0x53f496] [@ libflashplayer.so@0x53f496 ] → [@ libflashplayer.so@0x53f496] [@ libflashplayer.so@0x53f496] [@ libflashplayer.so@0x53f496 ] [@ libflashplayer.so@0x53f4b4 ]
blocking-fennec1.0: --- → -
Summary: crash [@ libflashplayer.so@0x53f496 ] → crash [@ libflashplayer.so@0x53f496 | TimerThread::UpdateFilter]
Crash Signature: [@ libflashplayer.so@0x53f496] [@ libflashplayer.so@0x53f496] [@ libflashplayer.so@0x53f496 ] [@ libflashplayer.so@0x53f4b4 ] → libflashplayer.so@0x53f4b4 ] [@ libflashplayer.so@0x538516 ] [@ libflashplayer.so@0x538886 ] [@ libflashplayer.so@0x53ca42 ] [@ libflashplayer.so@0x53de1e ] [@ libflashplayer.so@0x53f106 ] [@ libflashplayer.so@0x53f166 ] [@ libflashplayer.so@0x53f49…
Component: General → XPCOM
Product: Fennec Native → Core
QA Contact: general → xpcom
Summary: crash [@ libflashplayer.so@0x53f496 | TimerThread::UpdateFilter] → crash in TimerThread::UpdateFilter @ libflashplayer.so@0x53...
Version: Firefox 13 → 13 Branch
It's #13 top crasher in 14.0b3.
Version: 13 Branch → 14 Branch
With combined signatures, it's even #5 top crasher in 14.0b3.
blocking-fennec1.0: - → ?
Keywords: topcrash
Assignee: nobody → snorp
blocking-fennec1.0: ? → +
Snorp, #5 crash we need some evaluation here
That stack trace looks wrong, there is no entry point to the plugin from there.

I wonder if this is basically the same crash as bug 759109.
I don't see anything obvious here, at least. As I said in bug 759109, we remove timers when the plugin is stopped. Some STR would certainly be helpful.
Keywords: qawanted
blocking-fennec1.0: + → -
Crash Signature: [@ libflashplayer.so@0x538516 ] [@ libflashplayer.so@0x538886 ] [@ libflashplayer.so@0x53ca42 ] [@ libflashplayer.so@0x53de1e ] [@ libflashplayer.so@0x53f106 ] [@ libflashplayer.so@0x53f166 ] [@ libflashplayer.so@0x53f496 ] [@ libflashplayer.so@0x5… → [@ libflashplayer.so@0x538516] [@ libflashplayer.so@0x538886] [@ libflashplayer.so@0x53ca42] [@ libflashplayer.so@0x53de1e] [@ libflashplayer.so@0x53f106] [@ libflashplayer.so@0x53f166] [@ libflashplayer.so@0x53f496] [@ libflashplayer.so@0x53f4b4] …
Whiteboard: [native-crash] → [native-crash], str-wanted
Crash Signature: libflashplayer.so@0x53f4b4] [@ libflashplayer.so@0x538556] [@ libflashplayer.so@0x53f1a6] [@ libflashplayer.so@0x53de7e] → libflashplayer.so@0x53f4b4] [@ libflashplayer.so@0x538556] [@ libflashplayer.so@0x53f1a6] [@ libflashplayer.so@0x53de7e] [@ libflashplayer.so@0x53884a]
Pretty sure this is the same root issue as 750217, duping
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 750217
Crash Signature: libflashplayer.so@0x53f4b4] [@ libflashplayer.so@0x538556] [@ libflashplayer.so@0x53f1a6] [@ libflashplayer.so@0x53de7e] [@ libflashplayer.so@0x53884a] → libflashplayer.so@0x53f4b4] [@ libflashplayer.so@0x538556] [@ libflashplayer.so@0x53f1a6] [@ libflashplayer.so@0x53de7e] [@ libflashplayer.so@0x53884a] [@ libflashplayer.so@0x53f5a6]
Crash Signature: libflashplayer.so@0x53f4b4] [@ libflashplayer.so@0x538556] [@ libflashplayer.so@0x53f1a6] [@ libflashplayer.so@0x53de7e] [@ libflashplayer.so@0x53884a] [@ libflashplayer.so@0x53f5a6] → libflashplayer.so@0x53f4b4] [@ libflashplayer.so@0x538556] [@ libflashplayer.so@0x53f1a6] [@ libflashplayer.so@0x53de7e] [@ libflashplayer.so@0x53884a] [@ libflashplayer.so@0x53f5a6] [@ NP_Shutdown | TimerThread::UpdateFilter]
You need to log in before you can comment on or make changes to this bug.