Status

()

--
critical
RESOLVED DUPLICATE of bug 732343
7 years ago
7 years ago

People

(Reporter: hackwrench1, Unassigned)

Tracking

({crash, stackwanted})

13 Branch
x86
Windows 7
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:13.0) Gecko/20120301 Firefox/13.0a1
Build ID: 20120301031135

Steps to reproduce:

Downloaded http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2012-03-01-mozilla-central-debug/firefox-13.0a1.en-US.debug-win32.installer.exe
Installed it. Ran it. Console window opened, text poured forth, it crashed.


Actual results:

https://crash-stats.mozilla.com/report/index/bp-8fa14a5d-3477-4077-a945-fda442120301
https://crash-stats.mozilla.com/report/index/bp-d101771a-5655-4283-82e2-56b782120301
https://crash-stats.mozilla.com/report/index/bp-2986e797-d75b-4bfc-91ae-ce3e22120301


Expected results:

Debug build should have kept running and eventually displayed a browser window.

Updated

7 years ago
Severity: normal → critical
Status: UNCONFIRMED → NEW
Crash Signature: [@ DebugBreak] [@ mozglue.dll@0x1026]
Component: Untriaged → Build Config
Ever confirmed: true
Keywords: crash
QA Contact: untriaged → build.config
We don't have symbols for hourlies ... we need a stack trace here.

Updated

7 years ago
Keywords: stackwanted
(Reporter)

Comment 2

7 years ago
So, what does one do in this instance to get a stack trace?

Comment 3

7 years ago
(In reply to Robert Claypool from comment #2)
> So, what does one do in this instance to get a stack trace?
See https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg
I'm not sure that you can with the hourlies since we don't post symbols for them ...

Do the optimized hourlies crash on startup for you too?
(Reporter)

Comment 5

7 years ago
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2012-03-01-03-11-35-mozilla-central/firefox-13.0a1.en-US.win32.installer.exe did not crash. The last modified on http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2012-03-01-mozilla-central-debug/firefox-13.0a1.en-US.debug-win32.installer.exe is 29-Feb-2012 15:42, So I don't know how it's an hourly. What's the point of making a debug build that you can't make a stack trace of anyways, hourly or not?
Oh, these are nightlies.  Interesting ... I would expect us to get symbols from crashes in debug nightly builds.

Comment 7

7 years ago
I have a system error prompt: "Unable to start the program because MSVCR100D.dll is missing on your computer" although I have Microsoft Visual C++ x86 redistributable installed on my computer.
The debug CRT isn't redistributable, you have to have the compiler installed.
(Reporter)

Comment 9

7 years ago
In the console window I was getting error messages like Cannot load DLL (non-alphanumeric characters) because it cannot be found.
That should be fixed as of a couple hours ago.
Meaning that the patch will be in tomorrow's nightly.

Updated

7 years ago
Depends on: 730051
(Reporter)

Comment 12

7 years ago
I've got Assertion failure: Must not use HTMLContentSink for styles and scripts.. at e:/builds/moz2_slave/m-cen-w32-dbg/build/content/html/document/src/nsHTMLContentSink.cpp:704

http://mxr.mozilla.org/mozilla-central/source/content/xml/document/src/nsXMLContentSink.cpp#704

Comment 13

7 years ago
(In reply to Robert Claypool from comment #12)
> I've got Assertion failure: Must not use HTMLContentSink for styles and
> scripts.. at
Is it still a crash? If not, file a new bug and close this one as fixed.
(Reporter)

Comment 14

7 years ago
Still a crash. Been using screen recording software to go back and look at the output.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 732343
(In reply to Robert Claypool from comment #5)
> 15:42, So I don't know how it's an hourly. What's the point of making a
> debug build that you can't make a stack trace of anyways, hourly or not?

It's kind of complicated, FWIW, and we just don't have a great solution. Sorry.
You need to log in before you can comment on or make changes to this bug.